Sys-vpn works on fedora-32-minimal but fails on other minimals

I have been trying to setup a VPN ProxyVM using both the qubes-tunnel method as well as using iptables and cli scripts, and have not been able to get either working.

I erased and reinstalled my laptop so have a fresh install where I have not done any configuration other than trying to get a proxy vpn going so I can hopefully rule out other config tinkers I’ve done in the past that might affect things.

I tried the fed32 minimal template using this method and viola! It worked!

Then i tried the same thing, but using debian, nada. I couldnt get any farther than sucessfully running

sudo openvpn --cd /rw/config/vpn --config openvpn-client.ovpn

and then


but when i tried steps after the DNS handling script nada.

I then tried just switching the base template, using the tested sys-vpn but switching from fed32 (working) to deb10, and nada?

Since centos seems to be a wee bit in flux I would prefer to go with the deb10 template since thier LTS is longer then fed vers.

So my question to try to figure out is why? I installed (copy an pasted) the packages as suggested on the qubes docs minimal page for FirewallVM, NetVM, USB qubes and VPN qube; but this is the only difference I can see between what I did when using fed32 and deb10. Is there an additional package that might be missing that would cause the DNS handling script not to work?

Thoughts? Please?