Sys-usb is crashing system

I installed Qubes OS a few days ago and although I already have a few years of Linux experience, the system is causing me considerable problems.

The installation failed twice, the third time it worked.

Now, however, I cannot boot without “qubes.skip_autostart”, otherwise I find myself in a reboot loop. The system also crashes, if I start the qube manually after succesful boot of dom0.
The reason for this is sys-usb, which was created automatically. (I have already deleted this and had it recreated, without success).

Unfortunately, I cannot find out why this is happening.

journalctl output can be found here

Thanks in advance

Try to remove all PCI devices from sys-usb and add them back one-by-one to find the one that is causing this issue.


thanks for your answer.

i currently have 4 devices assigned to the qube and as far as i can see, device 70:00.4 is the trigger. this is my usb hub/switch which has mouse and keyboard connected, which has 2 channels so i can switch depending on whether i’m using the pc or the notebook

Can you connect your USB switch to a different USB controller and not to 70:00.4 for a test?

Hey, thanks for your answer. I’ve tried that now and at least my system didn’t reboot on boot, but I see an error message flash up, but it disappears immediately so I can enter my crypt key.

Now I get to the login screen and I can neither move the mouse nor type anything. The screen also freezes, so a process or the system is probably hanging.

Unfortunately, I can’t read the error message and when I look in the journal, I can’t find anything about it. But I think it says: “cannot start …sys-usb…”

If you boot the system with qubes.skip_autostart and then start sys-usb manually then can you see the error message?

Unfortunately not, but I just filmed in parallel with my smartphone and the error message was: "“Failed to start qubes-vm@sys-usb.service … See systemctl status … for details”
So I did that and the error message there is:

(After switching USB ports I can at least start sys-usb after booting, i.e. when it is completely booted, without the system crashing. At least that’s progress)

So I did that and the error message there is:

– Boot 95a3bc3ac61a43cba1b91f4969ca4838 –
Apr 17 21:12:54 dom0 systemd[1]: Starting qubes-vm@sys-usb.service - Start Qubes VM sys-usb…
Apr 17 21:13:00 dom0 qvm-start[4321]: Start failed: Angeforderte Operation ist nicht gültig: PCI device 0000:71:00.0 is in use by driver xenlight, domain disp-sys-usb, see /var/log/libvirt/>
Apr 17 21:13:00 dom0 systemd[1]: qubes-vm@sys-usb.service: Main process exited, code=exited, status=1/FAILURE
Apr 17 21:13:00 dom0 systemd[1]: qubes-vm@sys-usb.service: Failed with result ‘exit-code’.
Apr 17 21:13:00 dom0 systemd[1]: Failed to start qubes-vm@sys-usb.service - Start Qubes VM sys-usb.
– Boot fdca0c79d00e4b0a90d6ed86fa405e22 –

Sorry, this sentence is german: “Angeforderte Operation ist nicht gültig” it means Operation not permitted.

It seems that you have multiple qubes with the same device attached disp-sys-usb and sys-usb. After the first one of them is started and claimed the attached PCI device then second one can’t start because the device is already taken by other qube.
Disable autostart for disp-sys-usb or sys-usb whichever you don’t use. Or remove the attached PCI devices from them so you won’t have the same PCI device attached to both of them.

Oh, thanks. They got created automatically by an qubes command or qusal, I am not sure tbh.

Whats the difference between the three usb qubes?

I don’t know how qusal works so I can’t answer this.
But you have 2 USB qubes and not 3.
sys-usb disposable qube based on default-dvm disposable template based on some TemplateVM (debian-12-xfce or fedora-39-xfce by default)
disp-sys-usb disposable qube based on dvm-sys-usb disposable template based on separate tpl-sys-usb TemplateVM