Sys-usb field start after attach pci sdd

sys-usb field start after attach pci sdd

qvm-start sys-usb
Cannot connect to qrexec agent for 60 seconds, see /var/log/xen/console/guest-sys-usb.log for details

also I tried with no-strict-reset same error

Check the /var/log/xen/console/guest-sys-usb.log for details on why it fails.

Starting .[0;1;39msystemd-oomd.serv…pace Out-Of-Memory (OOM) Killer...
[2023-11-19 04:49:01]          Starting .[0;1;39msystemd-resolved.…e.[0m - Network Name Resolution...
[2023-11-19 04:49:01] [.[0;32m  OK  .[0m] Reached target .[0;1;[0m - System Time Set.
[2023-11-19 04:49:01]          Starting .[0;1;39msystemd-update-ut…rd System Boot/Shutdown in UTMP...
[2023-11-19 04:49:02] [    4.002519] usb 1-12: new full-speed USB device number 4 using xhci_hcd
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Finished .[0;1;39msystemd-update-ut…cord System Boot/Shutdown in UTMP.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39msystemd-oomd.servi…rspace Out-Of-Memory (OOM) Killer.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39msystemd-resolved.s…ice.[0m - Network Name Resolution.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Reached target .[0;1;39mnss-lookup.…m - Host and Network Name Lookups.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Reached target .[0;1;[0m - System Initialization.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39mfstrim.timer.[0m - Discard unused blocks once a week.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39mlogrotate.timer.[0m - Daily rotation of log files.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39mplocate-updatedb.t…Update the plocate database daily.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39mqubes-sync-time.ti….[0m - Update system time each 6h.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39mqubes-update-check… - Periodically check for updates.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39mraid-check.timer.[… - Weekly RAID setup health check.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39msystemd-tmpfiles-c… Cleanup of Temporary Directories.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39munbound-anchor.tim… the root trust anchor for DNSSEC.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Reached target .[0;1;[0m - Path Units.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Reached target .[0;1;[0m - Timer Units.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Listening on .[0;1;39mdbus.socket.[…- D-Bus System Message Bus Socket.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Listening on .[0;1;39mpcscd.socket.…art Card Daemon Activation Socket.
[2023-11-19 04:49:02]          Starting .[0;1;39msnapd.socket.[0m …et activation for snappy daemon...
[2023-11-19 04:49:02] [    4.129821] usb 1-12: New USB device found, idVendor=8087, idProduct=0a2b, bcdDevice= 0.01
[2023-11-19 04:49:02] [    4.129872] usb 1-12: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[2023-11-19 04:49:02]          Starting .[0;1;39mdbus-broker.servi….[0m - D-Bus System Message Bus...
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Listening on .[0;1;39msnapd.socket.…cket activation for snappy daemon.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Reached target .[0;1;[0m - Socket Units.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39mdbus-broker.service.[0m - D-Bus System Message Bus.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Reached target .[0;1;[0m - Basic System.
[2023-11-19 04:49:02]          Starting .[0;1;39mdracut-shutdown.s…tore /run/initramfs on shutdown...
[2023-11-19 04:49:02]          Starting .[0;1;39mpolkit.service.[0m - Authorization Manager...
[2023-11-19 04:49:02]          Starting .[0;1;… - Qubes base firewall settings...
[2023-11-19 04:49:02]          Starting .[0;1;39mqubes-network-upl…[0m - Qubes network uplink wait...
[2023-11-19 04:49:02]          Starting .[0;1;39mqubes-snapd-mount…ersistent snappy systemd mounts...
[2023-11-19 04:49:02]          Starting .[0;1;…ice.[0m - User Login Management...
[2023-11-19 04:49:02]          Starting .[0;1;39mxendriverdomain.s…Xen driver domain device daemon...
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Finished .[0;1;39mdracut-shutdown.s…estore /run/initramfs on shutdown.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Finished .[0;1;39mqubes-network-upl…e.[0m - Qubes network uplink wait.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Finished .[0;1;39mqubes-snapd-mount…-persistent snappy systemd mounts.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;…- Xen driver domain device daemon.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39msystemd-logind.service.[0m - User Login Management.
[2023-11-19 04:49:02] [.[0;32m  OK  .[0m] Started .[0;1;39mpolkit.service.[0m - Authorization Manager.
[2023-11-19 04:49:04] [.[0m.[0;31m*     .[0m] Job qubes-iptables.service/start running (4s / no limit)
[2023-11-19 04:49:05] .M^M.[K[.[0;1;31m*.[0m.[0;31m*    .[0m] Job qubes-iptables.service/start running (5s / no limit)
[2023-11-19 04:49:05] .M^M.[K[.[0;31m*.[0;1;31m*.[0m.[0;31m*   .[0m] Job qubes-iptables.service/start running (5s / no limit)
[2023-11-19 04:49:06] .M^M.[K[ .[0;31m*.[0;1;31m*.[0m.[0;31m*  .[0m] Job qubes-iptables.service/start running (6s / no limit)
[2023-11-19 04:49:06] .M^M.[K[  .[0;31m*.[0;1;31m*.[0m.[0;31m* .[0m] Job qubes-iptables.service/start running (6s / no limit)
[2023-11-19 04:49:07] .M^M.[K[   .[0;31m*.[0;1;31m*.[0m.[0;31m*.[0m] Job qubes-iptables.service/start running (7s / no limit)
[2023-11-19 04:49:08] .M^M.[K[    .[0;31m*.[0;1;31m*.[0m] Job qubes-iptables.service/start running (8s / no limit)

There’s no relevant info in this part of the log. Can you post the sys-usb log starting from sys-usb boot until it fail to start?
You can also check these logs:
And sudo journalctl in dom0 terminal.

What is ‘sdd’? If it’s typo, then what puzzles me is why would you attach ssd to sys-usb? If it’s some external ssd in usb enclosure it should be already seen in some sys-usb. If it’s internal ssd (“PCI”, right?), then why attaching it to usb?

Anyway, if not already, you could try with

–persistent --option permissive=true

prior to start up sys-usb.

At the end, you could try to switch from HVM to PV mode and then try to attach (because of xhci_hcd), but the whole concept is misty for me and especially my last suggestion has serious security implications.