hi, on qubes 4.2 the sys-usb uses
appvm: default-dvm
template: fedora-38-xfce

inside template has many applications that i would like to remove, i only want to stay the minimal apps to make sys-usb use mouse and sometimes attach external ssds and a mobile 5g router. can someone help me and say what dependencies i have to install to make it work? i have a fedora-38-min backup from 4.1 and when i try to use it as template from appvm on sys-usb it doesnt recognize automatically the usb mouse and accept to use it, how can i fix this?

  • USB qube, such as the template for sys-usb: qubes-usb-proxy to provide USB devices to other Qubes and qubes-input-proxy-sender to provide keyboard or mouse input to dom0.

thanks, it worked like a charm.

BTW, there is a suggestion by one of Qubes OS core team members for a Hyperminimal sys-usb Qube. The details could be found here. If you like the idea and you have a Github account, please consider giving it a thumbs-up as encouragement. Hopefully they would consider spending more time on that.

Notably in 4.2 (and presumably earlier) the sys-usb qube cannot be headless, at least not without loss of function. Without Xorg installed & running, and a guivm qvm-prefs setting, the permission popups of the form

Source: sys-usb
'Do you want to allow the following operation'

will not display / will auto-deny. So there is currently a low ceiling on how stripped down sys-usb can be.

Sorry but can you please explain what exactly do you mean by low ceiling on how stripped down sys-usb can be?
If I use debian min or fedora min are there any difference in that matter?
I did get the popups of my keyboard but couldn’t get blueman to work…

I mean that currently you can’t strip out Xorg from the template that underlies sys-usb without losing the ability to arbitrate “ask” policies like this:

qubes.InputMouse	*	sys-usb	@adminvm	ask default_target=@adminvm

With a headless (meaning no X, not even for xterm) sys-usb the permission popups you should see after plugging in a USB mouse will instead be auto-denied.

This probably doesn’t relate to your issue. You would have had to remove even more packages from the minimal templates (thus “hyperminimal”) for it to happen.

If I were in your shoes troubleshooting your issue the first thing I’d try is opening a terminal in sys-usb and scanning the log you get from running journalctl for hints about what might be going wrong.

Ah thanks!
I’ll try to test it with minimal sys usb