Sys qubes failing to start due to Logical volume already existing

I had several crashes of my Qubes system, and now when I boot I get sys-net sys-firewall sys-usb failing to start. For context this is a very new Qubes installation.

When I used systemctl status to see what was going on for sys-usb & sys-firewall, I got the following (more to it which I can post):

loaded: (insert long path): service; enabled; vendor preset; disabled
skipping down

Can’t create snapshot vm-keepassxc-private-snap as origin vm-keepassxc-private is not suspended.

For sys-firewall it says:

"Logical volume vm-sys-net-volatile already exists in “qubes_dom0”

ERROR: Logical Volume "vm-sys-<vm-name>-root-snap" already exists in volume group "qubes_dom0" · Issue #3964 · QubesOS/qubes-issues · GitHub This github issue from a while ago seems to be the same issue.

Can anyone explain what has happened and how to fix it? Thanks.

Edit - A user in this post Logical volume "vm-sys-net-volatile" already exists in volume group"qubes_dom0" - #2 by adw suggested the following as a remedy, does anyone have comment on this approach?

"After my system crashed and rebooted I had the same error message. I was able to fix it by issuing the following commands in dom0:

dom0: lvdisplay (and searching for the path to the logical volume, e.g. lvdisplay|grep vm-sys-net-volatile)
dom0: lvremove (e.g. lvremove /dev/qubes_dom0/vm-sys-net-volatile)

My expectation was that the volatile logical volumes are only temporary. So by deleting it I only lose the temporary changes after the last reboot of the VM. It worked like expected, but I didn’t check for any data loss. I was able to boot the VM and all was working like expected."


Found from: ERROR: Logical Volume "vm-sys-<vm-name>-root-snap" already exists in volume group "qubes_dom0" · Issue #3964 · QubesOS/qubes-issues · GitHub

Success. I ran:
sudo lvremove qubes_dom0/vm-sys-whonix-private-snap

It successfully deleted. From there all VMs can start. I rebooted qubes to be sure. Everything comes up >cleanly.

1 Like

I see that you updated the above post. Some people, including some core developers, are interacting with this forum via email. They do not receive the edits made after 10 minutes. For this reason, it’s better to make a new post, not update the old one (and/or use quotations like I do here).

1 Like