Sys-net shutdown

Sys-net shuts down and I get an error: Cannot connect to qrexec agent for 60 seconds.
Additionally I receive the same error for “sys-firewall”.

Ultimately I am unable to open any qube. I am able use Dom 0 but cannot open any qube. After checking the logs it appears it’s a kernel problem or bios issue after an update. Is there a fix for this?

From what I can tell, this is caused by qubes-core-agent & qubes-core-qrexec being removed (not marked to hold/as dependency?) during the upgrade process.

You can try this:

  1. Open “Qubes Global Settings”
  2. In the top right, roll back the kernel in the “Default kernel used by qubes” setting
  3. Reboot

FWIW & much to my frustration, I’m also experiencing this with all debian-12 / bookworm “templates” currently. :scream:

I tried this and I’m still unable to access the other Qubes. Hope you find a fix as well.

To get back online you can try to do the following:

  1. Rename sys-net to something like sys-net_old
  • Disable “Start qube automatically on boot”
  1. Open a console in dom0 and enter:
$ sudo qubesctl state.sls qvm.sys-net

This ought build you a fresh sys-net qube using the “qubes defaults” selected in “Qubes Global Settings”.

I’m getting the same errors. Do you have an idea what can be causing this?

In my case, I’m certain that qubes-core-agent & qubes-core-qrexec are being removed during the upgrade process but, I believe this to be due to the fact that I am using debian-12-minimal template that I manually created.

I would find it strange if you had the same happening with debian-11-minimal or debian-11 templates as, I think there would be more users experiencing the same troubles.

With that in mind, check again in “Qubes Global Settings” and be certain that your default template & disposable template are debian-11 & debian-11-dvm OR debian-11-minimal & debian-11-minimal-dvm and, simply try to recreate sys-net using the steps above once more. Also, be sure to rename any old sys-net as well as disable/unselect “Start qube automatically on boot”.

Here’s what I had to do, clone my templates and configure them to debian.

qvm-clone fedora-36-dvm debian-11-dvm
qvm-prefs sys-firewall netvm sys-net

qvm-prefs debian-11-dvm template debian-11

qvm-prefs sys-firewall template debian-11-dvm

qvm-prefs sys-usb template debian-11-dvm
qvm-start sys-net

qvm-start sys-firewall

qvm-start sys-whonix

qvm-prefs default-mgmt-dvm template debian-11
qvm-prefs personal template debian-11
qvm-prefs untrusted template debian-11
qvm-prefs vault template debian-11
qvm-prefs work template debian-11

Once I was able to get back in the qubes I backed up my templates. I’m going to reinstall and configure them to avoid any other problems.

1 Like