Sys-net crashing with message "connection to the VM failed" when using WLAN card

Hi all,

I’m new to Qubes, and have been trying to set things up for the past day or so. One specific bug I have kept running into is getting my wifi card (an rtl8821CE) working. When the wifi card is not attached and only the ethernet device is, sys-net boots up and performs normally. However, when the wifi card is added as a device, I am met with a “connection to the VM failed” error. I tried searching the logs and saw a “kernel panic - not syncing” error, however I was unable to find the cause. Some of my troubleshooting methods included manually installing the drivers from here, updating everything I can, and other smaller things. I am running debian as the default, however I have also tried using fedora and got the same outcome. I can’t upload attachments as a new user, so logs for the sys-net qube are here

Any help is appreciated!

Is the original driver blacklisted?

Run this in the template directly, shut it down and then restart sys-net:

echo "blacklist rtw88_8821ce" | sudo tee -a /etc/modprobe.d/blacklist.conf

Still no luck, unfortunately. Same error shows up.

Are you sure that the driver from that github link is really installed? Can you explain the process you followed to be able to install it?

Open template VM terminal as root
apt install bc module-assistant build-essential dkms
m-a prepare
git clone
cd rtl8821ce
Shutdown template VM, restart sys-net
(also tried the same steps with sudo as user in sys-net, but reverted when nothing changed)

Did you do the git clone command in the Template? Since they are supposed to have no network access I’m not sure if you did that inside of it or outside then copied the directory.

1 Like

I gave temporary access through a firewall. I know it’s technically a security hole, but I’m still just trying to get settled so I’m not too concerned.

Next time you can download the needed files in another VM and copy it to the template safely:

About your issue, have you tried to run the original VM kernel instead of the Qubes provided one? You can select “provided by qube” in the settings advanced tab and see if it changes anything (reboot the VM when you save).

Switching to the original kernel did it! Do you think it would be prudent to investigate further and make a bug report?

Also, on the topic of files: I’m still new to this, however isn’t it equally as bad to transfer files from less trusted to more trusted VMs? I feel like I might not have totally understood the security model if I’m wrong there.

I think this is more a kernel issue than a Qubes issue, so I don’t think opening an issue on github is necessary.

It depends on what you’re transferring and how much trust you’re personally giving to each qubes. Most of the time you’ll be fine transferring files between them. It’s a good practice to do it this way, but if the file is trusted it’s not really a problem.