Syncthing in Qubes OS

Hello there.
I have a Qube setup to run Syncthing which I use to sync my data between my laptop and my android device. It works only when I allow global discovery and relays in Syncthing configurations. I am looking for a method so that I can work my syncing with local network discovery only. Can a VM be allowed via ssh tunnel or port forward to other device. What if I want to use proxyVM for my syncthing qube. Is it possible? I have not much understanding in qubes firewall so any help will be appreciated.

You’ll probably have to port-forward. But one thing you may be able to do is use the qube’s firewall settings to only allow access to the local network. Then you shouldn’t have to worry about it reaching to the global relays.

I am not using Syncthing for some time now but what I remember is that if you turn off global discovery it is good to point each of the clients to exact IP address of the other one and it works then. So in this case set phone IP to static and AppVM Syncthing client to this IP. For Qubes firawall you may set it in AppVM setting to limit outgoing connections to only this one IP. for example 192.168.1.50/32

How to do that?

Adding 192.168.1.1/24 to “Limit outgoing internet connections to…” on the “Firewall rules” tab on the qube settings, I would say.

I’m bumping on old thread but I hope others will find the help as I haven’t been able to find any newbie friendly steps to get this working. I created VMs off the debian template and edited the firewall rules in the qubes settings . However I still cannot get local discovery and I’m not able to connect. Can someone who has a working syncthing please help me/us out.

Adding 192.168.1.1/24 to “Limit outgoing internet connections to…” on the “Firewall rules” tab on the qube settings, I would say.

I did this

I am not using Syncthing for some time now but what I remember is that if you turn off global discovery it is good to point each of the clients to exact IP address of the other one and it works then. So in this case set phone IP to static and AppVM Syncthing client to this IP. For Qubes firawall you may set it in AppVM setting to limit outgoing connections to only this one IP. for example 192.168.1.50/32

I have it pointing to my IP address on a different computer .

It could be that syncthing has to connect first to relay servers in order to identify that your other computer is on the local network. But at this point it’s not an issue with Qubes. You could try looking up how to use syncthing exclusively on a local network / offline.