Suspend resume issues (gen1 thinkpad x1 yoga)

I looked through some postings and tried things like disabling hyper threading but am still not able to get suspend to resume. One thing i noticed was at least for 4.1 it seemed like some people had it working before but now dont, I honestly have never been able to get suspend to work on my laptop nor desktop. I put it into suspend and then can’t wake it up again. This is less problematic for my desktop (was just trying to save some electricity and be green) but with my laptop its more of a problem, when i put it to sleep it clearly is “asleep” as the little power button slowly fades in/out (slow blinks?) as it did when win was on it, but I cant seem to wake it up pressing the power button doesnt seem to do anything and this laptop doesnt have a fn/power option.
Thoughts would be appreciated.

Am running 4.1 rc3, with KDE if it matters, on a thinkpad x1 yoga gen1

Very few machines give you reliable suspend on Qubes. See here for a list: Community-recommended computers

I wonder how to troubleshoot this?

I was looking for a standard step-by-step guide to follow in the case of hardware issues.

While working for a while now on QubesOS 4.1 I noticed the following issues:

  1. When the Xfce Power Manager turns off the screen, it does not really turn off, it just turns blank, while I set it to turn off after 10 minutes but it remains blank so in the dark you can continue to see the blank screen glowing light. For hours. When I move the mouse the login screen returns which then disappears after a while but the screen remains on.

I wonder how to troubleshoot this?

  1. When I suspend and Resume the laptop the external HDD (block device) have disconnected.

I would like to know in what log file I can have a look to see the cause of the issue to try find a solution for the issue. Is there an specific thing I need to look for in this log file?

Or is this very low-level type of stuff not easy to solve?

Don’t know about the second isseu.

Before talking about suspending, why not clarify whether your computer is supporting S3 sleep or S0 sleep? Suspend in a Ubuntu 21.10 bootable media or Windows 10/11 can help determining which sleep mode your computer is supporting. Basically in S3 sleep your computer is not breathing (cpu fan will not make noise), while in S0 sleep fan will make noise and computer will make heat.

If you want S3 sleep but your computer provides S0, go to your BIOS and enable it in BIOS; if your BIOS does not have “Linux S3” option showing up, try updating your BIOS version.

I am also worrying about suspension of my laptop (Thinkpad L15 Gen2) and I am on the side of S3 sleep. What about you?

My machine supports S3 sleep. If I manually suspend and wait the 30 seconds it suspends just fine.
My issue relates to if I want to computer to continue running overnight, or for long periods of time but with the screen off. I can’t seem to accomplish this as QubesOS does not seem to be able to turn off the screen correctly.


1 Like

I would love to have figured this out on my desktop. I don’t know if it helps but I had the exact same monitor (desktop so not quite exact i guess?) problem in 4.0 and 4.1 XFCE but on a whim i tried KDE and now my monitors turn off completely? Go figure.