Surface pro 2017 Qubes Os boot error

Hello, as always a lamer asks for help
I installed qubes os on my surface

In the end I decided to install Win10
I made a usb stick in the bios changed the priority of the loader
It had no effect, loading the box with the password (the drive was encrypted with luks)
Made a few attempts, I tried to poke the bios on
And because I do not know deleted qubes os boot loader in the bios
After that, I have nowhere to boot (flash drive does not see)
On the ssd in the bios is an error indicator
couldn’t find a bootable operating system. check the boot configuration to try to fix this
Any ideas or is it a rock now ?

Translated*

What does the indicator say exactly?

Did you want to setup miltibooting, or did you try to simply remove Qubes and install only Windows?

Perhaps this could help: Installation troubleshooting | Qubes OS

yea that happened with me too, for some reason, the grub installed by qubes is not visible and does not show up as a boot option,
If you know how to add boot option manually do that, and by this i mean installing grub manually via command line. you can do this by booting into a linux live cd and running os-prober etc.

What i did was. I first installed arch through calamares installer.
then after that. I installed qubes and did manual partitionning and replaced all the partitions of arch like by like with qubes except the fat32 efi partition. I did not choose to reformat it.
and this worked.
but i am sure there is an easier way, than installing an entire different os just to install grub.

1, indicator show about not finding a device or an error
No text (
2 il try delet qubes os and install windows
3. I’ll read it and try to figure it out, but introductoryly, it throws me into an error from the BIOS boot icon
Ty

oh that sounds very encouraging.I don’t know how to run through the command line, but I think I can find it on the Internet with live сd did you have any problems with detection? because I can’t really understandwhy does not detect a flash drive with a new OS
If you describe your steps in a little more detail, I will be very grateful)

In this case, this should not be a problem with Qubes but with Windows, which can’t recognize your SSD for some reason (or problem with the SSD?). It doesn’t matter what is written on it, because Windows can wipe it all and install itself – under normal conditions. Perhaps you can try asking on Windows forums.

its not a rock. sorry my bad. Don’t bother with anything. just go to microsoft site and see instructions for resetting surface, that should work

Official methods do not work alas, I myself do not really understand how it works (the problem)
Does not detect the usb and the ssd indicator light is on (can it be because the ssd is encrypted by luks?)
I am wondering if there may be an option to reset?
Since qubes os system is installed but there is no qubes os bootloader in bios (

Official methods do not work (

try the following trouble shooting

  1. the issue why your windows 10 installation does not boot is because you have probably selected the wrong option in rufus while making the usb installation stick for windows 10
    try different creation option for usbs tick uefi gpt and uefi mbr

Also your information is not sufficient
write down the exact steps you took in detail to arrive at this state and i will be able to help you \

The drive being encrypted has nothing to do with not being able to boot off of an external usb stick. if you can get to the white screen on surface devices where you can schoose boot list order all is going to be fine.

Do the below

  1. download calamares installer from this site ALCI - Arch Linux Calamares Installer download | SourceForge.net
  2. go into rufus on a separate pc with thi siso and make a installation disk
  3. put it into surface press volume and power keys together
  4. go into boot menu and change priority
  5. boot and install another os.

you can do this with any distro you want, arch ubuntu and it should work

Also i have pro6 lying here, tell me exactly all the steps you did and i will brick mine to see whats the issue.

1 Like

Oh actually I managed to reinstall windows
I suspect that this could be due to a bad usb port connection …
Ty all for help
I run my surface with liveCD windows
Clean my ssd
And try reinstall but i reboot my Surface 5-7times because i think i had bad connection
Ty for help all