Stuck at boot after Sys-USB created for USB bootable Qubes

I installed Qubes OS 4.1.1 stable on a USB SSD. It used to boot, but once I created sys-usb, rebooting the USB SSD shows the following error. I also have an internal NVMe with QOS installed.

Warning: /dev/mapper/qubes_dom0-root does not exist
Warning: /dev/qubes_dom0/root does not exist
Warning: /dev/qubes_dom0/swap does not exist
Warning: crypto LUKS UID 6595d7ec-ea6a-4be4-adab-616B424296fe not found

Generating “/run/initramfs/rdosreport.txt”

Entering emergency mode. Exit the shell to continue.
Type “journalctl” to view system logs.
You might want to save “run/initramfs/rdsosreport.txt” to a USB stick or /boot after mounting them and attach it to a bug report

Press Enter for maintenance (or press Control-D to continue):
[223.659165] dracut-initqueue[486]: Warning: Not all disks have been found
[223.659268] dracut-initqueue[486]: Warning: You might want to regenerate your initramfs.

I think it might be related to the sys-usb as per one user at

which was stated as “problem was leaving ‘Create USB qube holding all USB controllers (sys-usb)’ enabled while my boot drive was USB”.

Is there a way to disable sys-usb or uninstall it from the USB QOS411 from tty/QOS repair disk?

You can add qubes.skip_autostart to the kernel parameters when you boot, it will allow you boot without starting sys-usb

This is how you remove sys-usb

Sounds like the UUID in your grub.cfg doesn’t match the UUID of the disk - or the disk is not detected/available. If you access the GRUB config (press e to edit at the GRUB menu), does your kernel line end with:

module2 /vmlinux .... rd.qubes.hide_all_usb

– and if so, can you temporally remove the rd.qubes.hide_all_usb and boot (F10 or Ctrl-x)?

1 Like

Thank you very much!!
It worked.

Is there a way to ensure that sys-usb qube handles only usb devices other than the bootable usb during boot?

I removed rd.qubes.hide_all and also included qubes.skip_autostart in kernel parameters while booting, and I am in the OS now.
Thank you.

I don’t think you can use sys-usb when you are booting from USB, but maybe it works if you have multiple USB controller and can assign one to dom0 and one to sys-usb.

1 Like

You are right. The sys-usb shows 2 usb-controllers assigned to it in settings/devices. I will check it out later if there is a way to assign as you say.

Thanks again, that solves this problem.

1 Like