Standalone VM - connectivity issue after upgrade to 4.2

Recently I upgraded from 4.1 → 4.2 (dirty install). While running the dist-upgrade script in Dom0, I had some issues with upgrading my standalone VMs (Debian 11 & Fedora 38) so decided to sync their repos to 4.2 later on. Now the Fedora one works fine after running the standalone-upgrade script from Github however the Debian one is not connecting to the network.

Error messages:

  1. Update: Err:2 bullseye InRelease Temporary failure resolving ''
  2. Ping: 2 packets transmitted, 0 received, 100% packet loss, time 1045ms

Was there any error after running upgrade script in debian 11?
What’s the output of this command in debian 11 standalone?

ip a

Check the logs to see where did network init fail.

ip a displays the usual information (assigned IPs, netmasks, MAC, etc).

Same issue is happening in another Debian standalone where the upgrade script was not run. At this point am not really sure where the root cause is (tho likely somewhere in the Debian itself or one of the tools as Fedora is working fine). I’ll try to dig into the changelog and source code sometime later this week.

Does it have eth0 interface? Is it in UP state?
Try to ping, maybe it’s a problem with DNS.

Yes the interface is up and the problem is likely DNS.

The issue seems to origin from the network-manager service of the Qubes which can be attached to VMs. Something is happening afterwards where the /etc/resolv.conf changes to nameserver ::1 and then networking breaks. Now I have tried adding Qubes’s Virtual DNS addresses manually and restarting services + rebooting VM but that didn’t worked. When I removed the network-manager service from the VM, networking started working.

Interesting thing is the intended setup works fine in Debian 12 standalone VM with the same configs which somehow breaks Debian 11.