Standalone qube stopped being able to open windows

I have a standalone VM that I use for development. It is based on the debian 10 template and I have installed a variety of software on it related to rust development, vim plugins and alacritty.
Recently it stopped allowing me to open windows (terminals, firefox, etc) via the qube manager and I have no way of accessing it. Even the auto-updater does not open a window.

I can shut it down and start it up again no problem from the qube manager. I am using i3 as the WM, not sure if that could cause some issues.

Following are the logs of the qube

Thanks! :slight_smile:

Did this happen immediately after running an install or even removing
some packages? … you might have accidentally removed
qubes-core-agent-* packages (happened to me before, with similar result).

What happens if you try to launch by dom0 terminal?

Another idea: launch an xterm from Qube Manager.

Open Qube Manager, select your standalone VM, right click, select Run command in qube, and enter xterm.
If the xterm opens, check the error messages while launching your applications.

It could help the diagnostic initialized by @Sven.

Try starting any app like xterm using “qvm-run -a -p -v appvmname xterm” and see if there are any error messages while trying to load the app. If that fails try configuring the vm to run in debug mode.

As far as I can remember it was not right after any package removal or install, but considering it was used for development that did happen quite often. I did force a shutdown of the qube right before it stopped working.

I tested running qvm-run debian-10-development xterm and it tells me command failed with error code: 2

In the man-page for qvm-run it doesn’t specify the error codes, do you know what could be causing this?

Good advice, as I told Sven the error code I get is 2. I have also tried to run in debug mode but nothing changed.

You can do a lot with qvm-run -u root -p, if your qvm-run command is
working at all: just like working at the console. Start off with
qvm-run -u root -p ls
If qvm-run is no good, then the best you can so is sudo xl console
which should get you console access, and then you can see if you can
diagnose the problem from the inside.

Running as root from qvm-run works I can explore the file-system etc. However I am unsure how to diagnose the issue. The best thing I could come up with is to try to access the regular user via su user and perhaps see why regular execution isn’t allowed. su user blocks indefinitely, so does su root.

Other might have better ideas, but while waiting could you run the

dnf search qubes-core-agent | grep installed

dnf search qubes-core-agent | grep installed

Of course use apt instead of dnf … sorry

Hi, apologize, I should have mentioned, I installed everything that came with qubes-core-agent-* (after your first suggestion). This probably installed a bunch of unnecessary things but everything should be installed. Here is the dump you asked for:

qubes-core-agent/unknown,now 4.0.58-1+deb10u1 amd64 [installed,automatic]
qubes-core-agent-dbgsym/unknown,now 4.0.58-1+deb10u1 amd64 [installed]
qubes-core-agent-dom0-updates/unknown,now 4.0.58-1+deb10u1 amd64 [installed]
qubes-core-agent-nautilus/unknown,now 4.0.58-1+deb10u1 amd64 [installed]
qubes-core-agent-network-manager/unknown,now 4.0.58-1+deb10u1 amd64 [installed]
qubes-core-agent-networking/unknown,now 4.0.58-1+deb10u1 amd64 [installed]
qubes-core-agent-passwordless-root/unknown,now 4.0.58-1+deb10u1 amd64 [installed]
qubes-core-agent-qrexec/unknown,now 4.0.58-1+deb10u1 amd64 [installed]
qubes-core-agent-qrexec-dbgsym/unknown,now 4.0.58-1+deb10u1 amd64 [installed]
qubes-core-agent-thunar/unknown,now 4.0.58-1+deb10u1 amd64 [installed]

Yep, that looks good. Unfortunately I have no other ideas. My
recommendation at this point:

  1. use the console access you have (unman’s comments) to extract your data

  2. rebuild a new standalone VM and move your data in

  3. start nightly full backups of everything so you can always go back to
    a version that worked

On my system a full encrypted and compressed backup takes between 5-6
hours, so I kick it off when I go to bed and let the PC shutdown on
completion by itself. I always keep the last 5-6 days around on a 2 TB
external USB 3 drive.

I would consider that the minimum viable backup strategy. Obviously to
be really safe you want to have multiple backups in multiple locations
but since “work from home” started I find it difficult to keep that up.