Split-SSH issues

Hi everyone, I already tried to look for similar issues in the forum but I couldn’t find anything.

My problem

I followed the Split-SSH tutorial and I wanted to use KeePassXC to store SSH keys’ passwords and private keys.
I did all the steps correctly and double-checked, but when I try to Test my configuration and I run ssh-add -L under the ssh-client VM, notification does not appear and the terminal output is The agent has no identities..

Again, I already pasted all the scripts and codes in the three different VMs to enable the interconnection setup.
There’s one particular detail in my specific config: I use a Yubikey instead of a password to unlock the ssh-key-database KeePassXC’s database.

Thanks for the help

Not familiar with that tutorial, since I roll my own multi-identity solution.
But the principle will be the same.

Since no notification appears, I suspect you have not followed the steps
correctly.

  1. Confirm that the keys are in whatever qube you are using to store
    them, using ssh-add -L in that qube (vault if you have blindly
    followed the tutorial).
  2. Check the inter-qube connection -
    In client - confirm you have SSH_AUTH_SOCK correctly set - env
    In dom0 - check policy for qubes.SshAgent is set to ask.