Splash / login screen broken

Hi guys,

I tried to apply a fix from the documentation (See here`) and ran grub2-mkconfig to apply the changes.

I ended up breaking the Qube OS splash screen and the drive unlocking screen. I tried to revert my changes (and apparently missed my backing up the edited /etc/default/grub)…

Can someone share the default values of the /etc/default/grub file ? Or correct mine :

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXXX rd.lvm.lv=qubes_dom0/root rd.lvm.lv=qubes_dom0/swap plymouth.ignore-serial-consoles rd.driver.pre=btrfs rhgb quiet"
GRUB_CMDLINE_XEN_DEFAULT="console=none dom0_mem=min:1024M dom0_mem=max:4096M ucode=scan smt=off gnttab_max_frames=2048 gnttab_max_maptrack_frames=4096"
. /etc/default/grub.qubes-kernel-vm-support

Thanks a lot for your help fixing my stupidity if can be :-/


With the exception of the rd.luks.uuid=luks-[^ ]+ it looks like my file … :-/

– so an error in the luks-[^ ]+ part?

Hi !

Thanks @ChrisA for your quick answer :hugs:!

I just removed the UID from my file to post it here (I try to have this as a habit as UID can quickly become personnal data under GDPR :nerd_face:)

If it looks exactly like your file, I must have done something else… I reviewed all my terminal commands and could not find any suspicious actions :thinking:

Digging a little more into this, I came accross this thread which led me to this git repo. I’ll try to reset it with $ sudo plymouth-set-default-theme -R qubes-dark and see if it helps :wink:

I tried all options (except installing new plymouth theme on dom0) and as result the /etc/default/grub file has been deleted (but it doesn’t seems to change anything…).

Do you guys have other ideas on possible fixes ?