Sound Quality in Windows Qube has Extreme Poor Quality, Skips Always, Way to Adjust Latency?

I have finally gotten sound in Windows Qube, and gott both audio in and out, but the audio out is now extremely poor quality. It skips often and more skips than audio. It’s not the bit depth, just the skip, mostly empty sound so much skip

Does anyone know the answer? Where is everyone? Is everyone tired after the summits?

R4.0 or R4.1?

Which method? QWT on R4.1 or USB audio directly attached?

How much memory / vcpus are assigned to Windows?

When you keep everything idle (not use the computer but only play music)
… does that change the behavior?

1 Like

4.1

usb audio external attached

cant get mic in dom0

not sure mem. 2? 3? 4? 6? 8? does it matter? not a mem problem, i need a bigger audio buffer because of the extra latency due to qubes, windows isn’t coding for it and so everything sounds bad, so many skip

it was nearly idle when i tried

@qubesn00b wrote:

4.1 usb audio external attached

Ok, so you have a sys-usb and then attach that specific USB device to
windows using the device tray icon – right?

That means you are using usbip via qrexec into windows. It may be that
your sys-usb needs a bit more memory. This might be a similar issue then
what most experience trying to use a webcam with Qubes OS.

cant get mic in dom0

Makes sense, because dom0 can’t see your USB audio mic. When you have a
sys-usb, dom0 doesn’t see any USB devices.

i need a bigger audio buffer because of the extra latency due to
qubes,

I don’t think it’s the size of your audio buffer as much as the
throughput and speed of usbip via qrexec.

windows isn’t coding for it

Not sure what you mean by that. I am not using R4.1 but learned
yesterday during the summit that it has the possibility of an audio qube
and that theoretically it should also work with USB devices. Maybe
experiment in that direction?

I have my USB audio device connected to a USB controller that is
directly assigned to windows. No audio issues at all. Maybe that’s an
option for you too?

1 Like

i increased memory and virtual CPUs of sys-usb and the StandAloneVM. Audio still breaks up.

Tried controller, that didn’t fix it.

By coding I mean it seem like Windows has programming code to use a driver to give this device a certain buffer and takes into account certain latency. But due to sys-usb routing to the device instead of Windows directly accessing device, buffer needs to be larger. It maybe programming code of WIndows 7 does not take this into account.

I am using Windows 7. Maybe you are using 10? After my exerpiences with Cortana and Bing, I’d rather take a bubble bath filled with piranhas than use Windows 10.

to use windows 10 that share all data, why not have combined honor killing and lesbian coming out party? i can invite my family, cleric, officials, and cortana she can attend too and take requests during the party. or i can keep using windows 7 because 10 is too confusing for stupid girl like me

1 Like

Hope sys-audio in R4.1 will improve that for you.

1 Like

Moved this into the 4.1 user support category.

1 Like

Did you try emulated audio device? It needs to be set

qvm-features [windows-qube] audio-model ich6
2 Likes

I am having similar issues, with both USB audio and emulated output.

I have a hunch that it could be related to shared lanes of my attached GPU and the PCIe disk which the Windows VM resides on.
The lags when gaming is pretty consistent with the audio skips.

With certain GPU combinations, e.g. 0, 1 or 2 connected, with different seats and PCIe Link Speeds, I cannot decrypt nor reinstall Qubes on my PCIe disk.
I can still manipulate it without a GUI, but as soon as a display is involved, freeze.

1 Like

I did use this command in dom0 to enable the internal audio but my internal audio’s microphone won’t register any sound. I can hear from Windows 7 but can’t record audio. So I need to use external usb audio device but latency is very bad too bad to use.

Are you sure that didn’t forget to assign microphone to working VM via Qubes device widget?

1 Like

I did assign it. there’s no input signal in pavu either.

We are talking about integrated microphone or USB external?

Integrated mic should works well in dom0, that means it operates by pavucontrol which shows sound level and other things. Qubes sound tool forwards it to VM with audio agent (Linux based) or HVM via qemu emulated virtual device. It happens when you attach mic to VM via Device Widget or command line. If it is the case pretty strange that pavucontrol doesn’t show signal level in input section.

2 Likes

Have input jack in computer that receives both audio input and provides audio out for headset and is integrated device. When I plug in Sony hea dphones that were good for audio input and audio output back when used Windows 10 then can hear sounds from Qubes.

The output sound will show up in pavucontrol and will hear the output. When make input sounds by clapping hands there is no input showing in pavucontrol. I have device listed as input and output device, not just as headphone device.

As a result, I am not using this device in Windows for audio input. When use an external audio interface, then am attaching it. Win dows can’t see it if I don’t attach it. This attached USB device is what has broken audio that breaking always although Windows sees it and install driver for it…

This looks like an issue and perhaps not specific to Qubes, but Linux in dom0. It might be configuration problem I guess, look at profile to audio controller. I guess microphone doesn’t work in any VM, not only Windows.

With external audio device you could try setup audio-vm instead of direct device attaching, because Windows USB support based on QEMU experimental feature and it is difficult to tune or fix.