Sound not working after R4.1.1 update

Long story short:

  1. Using a Dell Inspiron 5593; sound worked on R4.0 and R4.1 for over two years

  2. After updating to R4.1.1, device’s sound output becomes unreliable–works in one VM but not another; sometimes works for a short while after restarting.

  3. Next day, sound has become completely non-functional and a reinstall of pulseaudio-qubes did not help.

  4. Pulseaudio mixer plugin in dom0 shows that sound is still being piped in from the VMs (channel volumes show change), but no amount of tweaking can revive sound on any output device.

Is anyone else experiencing this?

Does anyone have any fixes?

One fix I’m trying is downgrading dom0’s kernel from 5.18. However, in R4.1 downgrading is no longer as simple as changing the contents of /boot/efi/EFI/qubes/xen.cfg since the file no longer exists.

 


The above documentation should be updated (don’t have a Github account):

  • xen.cfg no longer exists

  • Grub’s submenu seems to be on by default (changing GRUB_DISABLE_SUBMENU to true doesn’t seem to change anything)

  • Messing with Grub seems risky–is there an alternative method for changing the default kernel?

  • Is there a way to just uninstall kernel-latest? E.g. sudo dnf remove kernel-latest? (Not foolhardy enough to find out myself)

Downgrading dom0’s kernel from 5.18 to 5.16 seems to have solved the problem.

Will report back if anything changes

I also had issues with sound cutting off after sometime with the 5.18.x kernels. I’m now using the 5.15 branch and there’s no issue. From what I know, sound issues started with kernel 5.17 and is still not patched.

Related issue:

1 Like

I haven’t mentioned this before, but when I first started using Qubes back in 2020 I faced a very similar issue on R4.0.3 using this same PC.

It went away with time (and patching), but I just didn’t expect it to get re-introduced.

I’ve had issues with sound cutting off too, although it was always after an absence from the computer. Began after the update, restart returns audio. It hasn’t bothered me greatly.

I have the same issue. Could you please let me know how you downgraded the kernel? I’m a bit lost too at this step, I couldn’t find the cfg file.

Edit : Nevermind I figured it out. It’s working by editing /etc/default/grub.
It seems it fixed the sound issue for me as well.

On the light blue screen that appears immediately after boot, before the grey splash screen, you are given the option to configure how your system boots. Among the choices is one that lets you boot dom0 with an older kernel.