(Solved) USB wireless RTL8192EU not connecting

Hi guys

Wondering if anyone can point me in the right direction. I have a USB wireless device. I attach it to the sys-net cube. It finds my modem, and I enter in my wifi password. The network manager applet in the top right then shows 2 dots with a swirly thing, and reports that it’s connecting. However, it then fails to connect.

I’ve verified that the password is correct.

lsusb in sys-net terminal says:

Bus 002 Device 002: ID 0bda:818b Realtek Semiconductor Corp. RTL8192EU 802.11b/g/n WLAN Adapter

I thought that perhaps the driver wasn’t installed, but when I look in my debian11 template (that sys-net is based on) I see this:

user@debian-11:~$ ls /lib/firmware/rtlwifi/rtl8192eu_*

So it looks like the driver is there.

Any ideas how to figure out why it’s not connecting?


I see debian-11 in the last block, have you tried running it on Fedora?
Also, what kernel are you currently running?

Thanks for the response.

user@sys-net:~$ uname -r

I found using “sudo journalctl -fu NetworkManager” in the sys-net qube this:

Aug 11 14:08:04 sys-net NetworkManager[543]: [xxxxxxxxxx.yyyy] device (wlxxxxxxxxxxxxx): Activation: (wifi) association took too long, failing activation

(Edited numbers out)
And that led me to people talking about disabling MAC spoofing. Only problem is I can’t figure out how to disable MAC spoofing in Qubes-OS. (Most of the hits I found were about how to enable MAC spoofing).

I’ll try using fedora-38 as sys-net’s template qube and see how that goes.

Do you have any way to install a newer kernel with phone tethering for example? The driver have some difference between 5.10.90 and 6.4.9. Maybe it could help with your issue.

(To install the kernel-latest package, open a dom0 terminal and run this command: sudo qubes-dom0-update kernel-latest kernel-latest-qubes-vm)

Oh man, things have gotten worse. :laughing:

After installing the kernel-latest package I rebooted to make sure it took, and then discovered that I can no longer log in. It’s not recognising my keyboard at the login screen anymore.

I booted into TAILS using a USB stick, and it had the same issue, couldn’t connect to the wifi. So then in the TAILS boot menu, I disabled MAC spoofing, and that fixed it (in TAILS). It’s a home desktop, so MAC spoofing isn’t really required anyway.

Before trying the kernel update, I tried disabling the MAC spoofing by deleting the /usr/lib/NetworkManager/conf.d/31-mac-spoofing… file in the fedora-38 template (can’t remember the exact name now), but that didn’t seem to do anything. Even after restarting the fedora-38 template, and the sys-net qube.

So… any ideas how to get past the login screen? Assuming the latest kernel still has the issue. Any ideas on how to disable MAC spoofing in Qubes-OS?


If it’s related to the new kernel (which seems odd), you can still boot on the old kernel by going in the “Advanced” menu. It’s what you see first with the countdown.

This seems to be the right file to delete based on this commit.
Make sure it’s removed in the template again.

Found the solution.

Turns out that the default rtl8xxxu doesn’t work with RTL8192EU.

To solve, got the rtl8192eu driver from here: GitHub - clnhub/rtl8192eu-linux: Realtek rtl8192eu official Linux driver, versions: (master),, 5.6.4 and (default)

Then followed the instructions (in debian11 template) to install it:

sudo apt install linux-headers-generic build-essential dkms git
cd rtl8192eu-linux/

This works even with MAC address spoofing re-enabled.

Thanks for the help (at one point I thought I was going to have to re-install my Qubes-OS, until you reminded me about the Advanced menu).

(I found the solution while searching someone mentioned blacklisting the rtl8xxxu driver but can’t find the page again, then I noticed this in my “sudo journalctl -fu NetworkManager” logs:

Aug 12 07:17:09 sys-net NetworkManager[526]: [1691839029.6718] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/platform/vhci_hcd.0/usb2/2-1/2-1:1.0/ieee80211/phy1/rfkill1) (driver rtl8xxxu)

So I tried blacklisting the rtl8xxxu driver without doing anything else (because I thought that it might automagically pick up one of the rtl8192eu drivers I saw in /lib/firmware/rtlwifi/, but it didn’t, so then I tried downloading and installing the driver as described above, and that fixed it. Then I re-enabled MAC spoofing, and it still worked.)

1 Like