[Solved] [rc4.2 r4] New Q Menu can be annoying

If it is in any way possible keep the Q Menu open after clicking on Q don’t let new windows close the Q Menu, open them though in background behind the Menu.

What happens:

  • Start Program A which loads AppVM
  • Click Q Menu and search for the other Application
  • Now once A pops up it shuts down Q Menu (not fun)
1 Like

You can use xfconf-query -c xfce4-notifyd -p /do-not-disturb -s true to disable notifications, I use it to disable notifications for 60 sec. on log in to avoid notifications making the menu unusable while I preload my qubes.


nice, thanks would try it out, should be the default setting though!
How exactly does the 60sec thing work and not really following how this affects the system, would all the pop ups be silent if this was permanent?

I edited the command, it needs to be true to disable notifications, and false to enable them.

I just use an ‘on login’ script, you can enable it in “Session and Startup”

xfconf-query -c xfce4-notifyd -p /do-not-disturb -s true
sleep 60
xfconf-query -c xfce4-notifyd -p /do-not-disturb -s false

It’s the same as clicking the dnd toggle in the notify widget, you just use a script to click the button.

1 Like

Related issue:


System Tools > Window Manager Tweaks > Focus tab > Activate Focus Stealing Prevention

Enabled only this, started new AppVM/firefox, selected Q Menu and let the mouse in there waiting on AppVM to start.
Firefox popped up in the Background without disturbing the Q Menu.