[SOLVED] Meld in fedora-36-minimal, fedora-37-minimal and debian-11-minimal files comparing not working

Can someone confirm that Meld in fedora 36-minimal compare files without issues? All I get is blank screen, although text is there (context menu indicates there’s content).
No preferences set in Meld can resolve issue (dark theme, font size, blahblah).

Comparing folder works without issues - Meld window content in case of folders compare is visible.

Couldn’t find any single hint searching out there.

Thnaks in advance

Hi there,
do You think this test may be enough?

Sorry, just checked: my template isn’t minimal, so this test is void!

I’ll let You know when I’m able to install it…

1 Like

It’s the same with fedora-37-minimal, but that is still testing…

Started meld from terminal, and tried files comparing in GUI
Terminal was flooded with error

TypeError: Couldn't find foreign struct converter for 'cairo.Context'

After researching, the solution was to install

fedora: gtk3, python3-gobject
debian: gir1.2-gtk-3.0 python3-gi-cairo

Meld is now fully functional

1 Like

With fedora it might be needed to downgrade python3-gobject-base, so install with --allowerasing

Hi there,
it’s a pair of day I’m trying…
I’m sure @enmus has found itself a good solution, but, what I can say…
Why all fedora-36 template updates correctly, but not the minimal one?
I’ve applied cacher modding to the template, but still getting:

update-minimal.log (4.0 KB)

What do You think?

Please open separate topic for this, so if we find a solution it wouldn’t be lost in this already solved thread with totally different subject. Thanks!

1 Like