Software (Reaper) launches but app doesn't appear after starting


New user, first post - novice would be an understatement.

I have installed a program called ‘Reaper’ to a Fedora 39 clone template by dragging the file into the terminal. I had to give the file executable permission to get rid of the ‘permission denied’ error by using the chmod command.

The program successfully installed and I have rebooted the system, refreshed the apps list for the template and added it to the template.

I then created a new qube to use just for this app using the fedora 39 clone. The app appears in the new qube app list, however upon launching the application I get a notification saying the app is starting, and then that the app has started, but the app does not appear.

The app file is stored in the home directory of the template.

I have reached a dead end searching for a solution so am posting here.

Hopefully someone can help!


That’s probably your issue.
The template /home directory is not inherited in app qubes.

Are you trying to install this program ?

I see.

Yes, that’s the program.

Would I need to move the folder to a new location?

You can move it to /opt instead, or you can uninstall and reuse the script and then ask it to install to /opt.
Also, from what I can see, the script creates the .desktop file in /usr/local/share/applications. You’ll have to move it too, because it’s also in the template’s private volume:

sudo mv /usr/local/share/applications/cockos-reaper.desktop /usr/share/applications/

I deleted the template, made a new fedora 39 clone and installed reaper again to /opt. I also moved the .desktop file using the line of code you provided, but the program still won’t open.

Did you edit the .desktop file and changed the executable path to /opt there?

I tried it and it worked for me.
In the installer I chose 1 for /opt and everything else was set to yes. The only last thing is to move the .desktop file with the previous command and refresh the applications in the template via the settings. Then when the template is shut down, the application was accessible in the app qube using the shortcut.

I haven’t edited the .desktop file. I’m not sure I follow the last bit. I installed to /opt as part of the installation when dragging the to the terminal.

I should point out that I don’t know any coding and am merely following instructions online.

That is precisely as I have done yet it still won’t open. Is there any way to check the .desktop folder has been moved to the correct place?

Can you share what’s in the file?

cat /usr/share/applications/cockos-reaper.desktop

[user@fedora-39-clone-1 ~]$ cat /usr/share/applications/cockos-reaper.desktop
[Desktop Entry]
Exec=“/opt/REAPER/reaper” %F

That seems correct.
Can you make sure you don’t have another one in /usr/local/share/applications:

ls /usr/local/share/applications/cockos-reaper.desktop

It should return “No such file or directory”.

Check if you have the binary:

ls /opt/REAPER/reaper

If you have only 1 .desktop file and the binary is available, open the template settings and update the application list. When done, turn off the template.
In the app qube, move “REAPER” to the “Applications shown in App Menu” list if not already done, and use the app qube shortcut to start it.

[user@fedora-39-clone-1 ~]$ ls /usr/local/share/applications/cockos-reaper.desktop
ls: cannot access ‘/usr/local/share/applications/cockos-reaper.desktop’: No such file or directory
[user@fedora-39-clone-1 ~]$ ls /opt/REAPER/reaper

I have done these steps also, still nothing.

I can do a fresh install of qubes and start from scratch if that may help eliminate any issues?

Can you create a fresh cloned template from fedora-39-xfce again and follow this:

# Open terminal in cloned fedora template
curl -x -LO
tar xvf reaper711_linux_x86_64.tar.xz
cd reaper_linux_x86_64/

# In installer, follow in order

# Move .desktop to correct directory
sudo mv /usr/local/share/applications/cockos-reaper.desktop /usr/share/applications/

# Open the cloned fedora template settings
# Go to "Applications" and refresh the list
# Click "OK"
# Turn off the cloned fedora template

# Create new app qube "reaper"
# Select the cloned fedora template as base
# Open the app qube settings after creation
# Go to "Applications" and add "REAPER" to the right
# Click OK

# Go the the app qubes "reaper" and open "REAPER"

I have an error at the first command line:

[user@fedora-39-clone-2 ~]$ curl -x -LO
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
curl: (35) OpenSSL/3.1.1: error:0A00010B:SSL routines::wrong version number

You typed “https” instead of “http” for

It works! Thank you so much for your help.

Is there any reason why it wouldn’t open when I tried installing it on the first template clone? It seems there is still an error somewhere during that installation?

Also could you please tell me what the ‘curl -x -LO’ part is about?

I’m not sure what went wrong before. Have you noticed anything different between these steps and the steps you used before when it didn’t work?

All templates don’t have access to the Internet, but they do have access to a proxy running in another qube that is used for updates (it’s set in Qubes Global Config). This proxy can also be used to download things to the template. If you try without it, you will see that you can’t get the file. -L will follow any redirection from the website, if there is one. -O will download the file with the name provided by the website.

The only difference would be that I installed the Reaper installation files onto a USB stick, moved that Reaper folder to the template home folder of the cloned template, took the file out of the reaper folder and put it directly in the home folder to give the executable permission, put the file back into the reaper folder where it came from originally and then dragged the .sh file to the terminal. All other steps were identical once I used the sudo mv /usr/local/share/applications/cockos-reaper.desktop /usr/share/applications/ command line that you provided.

Interesting. It seems this line may come in very useful should I encounter a similar issue in the future.