Snaps don't start consistently

I’m trying to use riot web snap in an App VM but I think the mount is failing for some reason. When I try to run riot-web sometimes it says

internal error, please report: running “riot-web” failed: cannot find installed snap “riot-web” at revision 96: missing file /var/lib/snapd/snap/riot-web/96/meta/snap.yaml

Then if I run df -h I get

df: /run/user/1000/doc: Operation not permitted
Filesystem Size Used Avail Use% Mounted on
/dev/xvda3 9.6G 4.8G 4.3G 53% /
none 9.6G 4.8G 4.3G 53% /usr/lib/modules
devtmpfs 1.9G 0 1.9G 0% /dev
tmpfs 1.0G 11M 1014M 2% /dev/shm
tmpfs 1.7G 900K 1.7G 1% /run
/dev/xvdb 19G 1.2G 18G 7% /rw
tmpfs 1.0G 12K 1.0G 1% /tmp
/dev/loop0 15M 15M 0 100% /var/lib/snapd/snap/aws-cli/130
tmpfs 31M 552K 30M 2% /run/user/1000
/dev/loop1 56M 56M 0 100% /var/lib/snapd/snap/core18/1997
/dev/loop2 62M 62M 0 100% /var/lib/snapd/snap/core20/975
/dev/loop3 100M 100M 0 100% /var/lib/snapd/snap/core/10958
/dev/loop4 163M 163M 0 100% /var/lib/snapd/snap/gnome-3-28-1804/145
/dev/loop5 66M 66M 0 100% /var/lib/snapd/snap/gtk-common-themes/1515
/dev/loop6 75M 75M 0 100% /var/lib/snapd/snap/joplin/8
/dev/loop7 160M 160M 0 100% /var/lib/snapd/snap/signal-desktop/354
/dev/loop8 33M 33M 0 100% /var/lib/snapd/snap/snapd/11588

Seems like all the apps I’ve installed are there aside from riot-web.
This seems to happen sometimes but not all the time and can be fixed by restarting the AppVM most of the time.

Think the issue may be related to this: All snaps showing as 'broken' - snapd -

I ran

cd /etc/systemd/system
ls *.mount | sudo xargs systemctl start

and it seemed to work, wonder if it’s a dependency order issue

OK here is a weird one, if I start the vm using the riot-web menu item it starts the vm but the riot-web won’t load. If I start signal-desktop it will load fine and riot-web will load fine if I try to start after that.

core-18 all reads as broken when I do that.

I have the same problem. After reinstalling/recreating a new AppVM it works. But restarting randomly breaks it. It works fine in a standaloneVM tho.

1 Like

Same here. I’ve been testing all the variables I can imagine. Still haven’t figured it out. If you find a solution, let me know.


Same issue here. Anyone found a definitive solution yet?

Have you thought posting the issue on: @restive ?

When I try the same I get:

Failed to start proc-xen.mount: Unit proc-xen.mount is masked.
Failed to start var-lib-snapd-snap-gnomex2d3x2d28x2d1804-161.mount: Unit var-lib-snapd-snap-gnomex2d3x2d28x2d1804-161.mount not found.
Failed to start var-lib-snapd-snap-gnomex2d3x2d38x2d2004-99.mount: Unit var-lib-snapd-snap-gnomex2d3x2d38x2d2004-99.mount not found.
Failed to start var-lib-snapd-snap-gtkx2dcommonx2dthemes-1519.mount: Unit var-lib-snapd-snap-gtkx2dcommonx2dthemes-1519.mount not found.
Failed to start var-lib-snapd-snap-joplinx2ddesktop-23.mount: Unit var-lib-snapd-snap-joplinx2ddesktop-23.mount not found.
Failed to start var-lib-snapd-snap-standardx2dnotes-87.mount: Unit var-lib-snapd-snap-standardx2dnotes-87.mount not found.

I posted the problem I have here on the forum: Snap applications do not start after reboot - snapd -