Snap apps - broken

when i boot up the appVM this notification shows up:

Device removed
Device /var/lib/snapd/snaps/Package Name_386.snap has been removed

and sometimes it says this when i open up one of the apps installed via snap:
Device removed
Device /tmp/sanity-squashfs-xxxxxxx (deleted) has been removed.

and sometimes:
Device removed
Device /var/lib/snapd/snaps/corexx_xxxx.snaps has been removed.

not sure what those two above mean.

Ive tried deleted the effected app updating the shortcut list shutting down the computer and trying to reinstall the app. but now i get an error message

ive tried to download in another AppVM with success.

but currently the two AppVMs i use with apps in it now show up as broken.

when i do snap list
it shows
bare broken
core18 broken
gtk-common-themes broken
and the apps i installed come back as broken

if i write the app name in terminal to get it to open it says
"cannot perfomr operation: mount --rbind /dev /tmp/snap.rootfs_EY03UQ//dev: no such file or directory

I hope someone can help. thank you.

i kind of solved it