Slow Internet on sys-net

I have a fresh Qubes installation which is connected via highend an ethernet 1200 Mbps connection. The internet is slow. I checked the speed on sys-net several times and got a download of 2-90 Mbps with an upload of 0.09-50 Mbps. Often the upload is faster than the download. I have also tried WiFi and ethernet and WiFi at the same time but didn’t notice a difference in behavior. I do get high speed internet on all non-Qubes devices on my network.

I did have some USB issues and at one time I ran the command recommended on the USB troubleshooting guide to force USB 2.0. I am not sure if this could be related but I wasn’t sure how to undo the following command to allow USB 3.0+ ports again

lspci -nn | grep USB | cut -d '[' -f3 | cut -d ']' -f1 | xargs -I@ setpci -H1 -d @ d0.l=0

could you share your computer specifications? (cpu, memory etc…)

Isn’t the max speed for USB 2.0 53Mbps?

Intel I9-1400K
2TB Samsung 990 NVMe 2.0c M.2 Internal SSD
Nividia 4090 ASUS ROG
ASUS ROG z790 WiFi Motherboard

My ports are USB 3.2 but I entered the command to force USB 2.0 because I thought USB 3.0 was interfering with resetting a device but I later discovered that wasn’t the issue

Check the sys-net logs, maybe there are some errors.
You can see it in Qube Manager → right click on sys-net → Logs and check the guest-sys-net-log and guest-sys-net-dm.log.

Here are my logs. Sorry I wouldn’t know if these are good and bad. I did a restart of the OS and just captured the logs immediately after sys-net started. it seems like there might be errors in there but let me know if I need to use the internet for a bit or give you logs that go farther back.

Logs removed for security reasons

As a side concern do any of the system logs like this or journalctl or var/logs/libvirt/libxl/libxl-driver.log have the potential to DOX me? I’m not sure if I need to be employing any data hygiene when requesting support here. Especially since I am prevented from deleting threads I create

Run test on or load your network some other way and check the messages in the log.
You can run this command in sys-net terminal and then run some network load:

sudo journalctl -f -n0

There is a MAC address in the log so it’s better to remove it.

You hopefully know that one can still download the old logs?
Your changes are saved!
maybe you can ask someone to remove it permanently if it’s important to you?

I don’t see any errors or anything relevant there.
Can you test your network connection speed in your LAN?
Try to download/upload files to some other device in your LAN.

Its very fast on other devices WiFi and Ethernet. Could it be related to forcing USB 2.0? I’m not sure how to undo this command.

lspci -nn | grep USB | cut -d ‘[’ -f3 | cut -d ‘]’ -f1 | xargs -I@ setpci -H1 -d @ d0.l=0

I did not know that thank you.

I’d check just to make sure it’s not something with your ISP like MTU or something.

I don’t think it’s related but nothing is impossible.
This change is not persistent and if you reboot it’ll return to default.

I just switched the template to Debian and I get 900 Mbps. Any thoughts on why that would fix it? Should I leave it? Are there other qubes I should switch to Debian?

What template did you have? Fedora? Which version?
Maybe it’s some problem with newer or older firmware. Or some other software.

fedora-38-xfce. its now debian-12-xfce. I assume the sys-net should not have a net qube assigned?

You can try fedora-39-xfce (if you prefer fedora instead of debian), it could have newer firmware/software that is the same as in debian-12-xfce.