Slow down and performance with Thinkpad L15 ryzen pro 7

I hope you can help me to find the problem i searched a lot here but i cant found some hint which resolved the problems yet.
I updated dom0 already to latest kernel. But its still same problem
I used befor 4.0 and there i never had this problems

  1. The Moving of windows have time lag in between aprox 1 sec from postition to next position.

  2. opening a a VM like the “work” Filemanger takes approx 25sec and the shutdown ~19sec

any idea how this could be solved ?
thanks br

i forgot but memory is extended to 64 Gig so enough i think.

There are several ongoing glitches in Qubes R4.1 afaik.

Also saying “latest kernel” is ambiguous - if you suspect that the problem lies in linux kernel (which is probable for new hardwares), you do not “update” to the latest kernel but rather try kernel-latest. The following documentation page talks about the difference between kernel, kernel-latest, kernel-qubes-vm and kernel-latest-qubes-vm.

You might also want to check if the CPU is running at the proper speed:

This issue is about Intel but I’ve seen similar reports about Ryzen CPU’s on the forum. Afaik a kernel parameter would fix it.
EDIT:
Here’s a solution for a slow Ryzen issue: [qubes-users] HCL - Lenovo P14s (AMD Ryzen 7 Pro 4750U) - #2 by Sven

1 Like