Simple tool set-up - monero wallet issues

Continuing the discussion from Tool: Simple Set-up of New Qubes and Software:

A while back I installed the monero wallet with this tool, and it worked fine. I deleted monerod-ws at one point because I was low on disc space. That problem has been resolved, and now I’m trying to get it set back up again but I’m having issues.

I deleted monero-wallet-ws after backing up my wallet and then uninstalled/reinstalled the “package”. I let monerod-ws run until it was synchronized and it gave the clear to run the wallet. Then I opened up monero-wallet-ws and tried both the CLI and GUI wallet, but both fail to connect to the daemon.

The CLI instantly fails with the message:
Error: wallet failed to connect to daemon: http://localhost:18081. Daemon either is not started or wrong port was passed. Please make sure daemon is running or change the daemon address using the 'set_daemon' command.
I checked and socat is running on monero-wallet-ws. Trying to change the daemon to use instead of localhost did not fix it.

The GUI is set up to use as a remote node like the Whonix documentation suggests, but after a few seconds of network status being ‘Connecting’ it switches to ‘Disconnected’.

I tried poking around and it seems the files needed to work are present on both VMs as well as dom0, so I’m not sure why this is happening.

Is there anything I need to do to give more details?

@deeplow - can you move this to User Support retitled - “Simple tool set-up - monero wallet issues”