Shutdown when closing laptop lid doesn't work

I’ve bought a new notebook and installed Qubes 4.2.1 on it.

I’ve tried to set up HandleLidSwitch=poweroff in dom0 config

vi /etc/systemd/logind.conf

Didn’t help. Worked fine on my old notebook with Qubes 4.1

Any ideas?

Do you see any info about lid in dom0 journal?

journalctl -b | grep -i lid

Does it work in other Linux systems on this notebook?

Maybe! There are three different settings for the “lid” action. The one you used is applied when the notebook is not plugged in.

When the notebook is plugged-in, the keyword is:

Third keyword is for the case the notebook is docked (if applicable) and is set to “ignore” by default.


I was able to fix this by setting lid close in power management to suspend. If it’s set to hibernate, lockscreen or turn of screen the changes in logind.conf don’t seem to apply.

1 Like