Shifting the white point

Just curious if someone has tried this in Qubes OS. I have successfully used Iris ( on regular Debian, but when I run the program in a qube, it reports success, but nothing really happens to the color temperature. Ideally, I’d love to be able to do this on a system-wide basis. Didn’t try running Iris from Dom0 - because not recommended; because I have doubts.

You’ll need to do this in dom0 because it handles all the display-related tasks. Also related:

1 Like

Much appreciated. Will try Redshift.

Just tried the instructions. All I get when starting Redshift is “Waiting for initial location to become available…” “Location: xx.x, yy.y”

Also found this:

Apparently, Redshift is unusable.

UPD: Iris works alright, though.

It’s trying to determine your location based on your IP:

Geoclue comprises the following functionalities :

WiFi-based geolocation (accuracy: in meters)
GPS(A) receivers (accuracy: in centimeters)
GPS of other devices on the local network, e.g smartphones (accuracy: in centimeters)
3G modems (accuracy: in kilometers, unless modem has GPS)
GeoIP (accuracy: city-level)

Of course it won’t work in dom0. Just follow the guide and create redshift.conf with your location manually.

redshift is usable. I use it. You just need to make sure you get your location right.

I did edit the config file as described at the link ([manual], lat=, long=…). And redshift is displaying the coordinates from the redshift.conf file when trying to start. That’s the xx.x and yy.y. I just didn’t put the numbers.

Now, the timezone on my computer is from a different location. Is redshift getting confused by that?

Run redshift with verbose flag and change lat:lon to different values -90,-80,…,-10,0,10,…80,90:
redshift -v -l -90:-90
If redshift works then with some values you’ll start to get these messages:

Period: Transition (2.69% day)

You’ll get them only on day/night changes.
For redshift to work you’ll need to have your time to be set correctly.