Settings override_redirect_protection to False

I’m trying to set the flag to allow a window to be fullscreen, I’m aware of the security issues, that is fine.

/etc/qubes/guid.conf is deprecated, so I set it using qvm-features as such:

qvm-features VMNAME gui-override-redirect-protection False

And it does not complain, but it doesn’t work either. How do I properly set this flag? This looks correct to me according to the man pages, but it doesn’t work neither give an error.

Solved with post by marmarek:

Reading from the GitHub issue, was it setting the feature to an empty string "" instead of False that fixed your issue @Eichieka ?

qvm-features VMNAME gui-override-redirect-protection ""

(Only repeating it here to make it easier for the next person to find the answer — for info, you can find a link to a specific comment in GitHub in the comment timestamp!)

1 Like