Setting default terminal settings for a TemplateVM

When you create a VM based on a TemplateVM, the gnome-terminal settings (font, color) are not inherited by default. This document describes how to set terminal defaults for all VMs subsequently created off a TemplateVM.

(Previously-created VMs are unaffected.)

This document only applies to gnome-terminal (the standard terminal) and not XTerm, etc.

Thanks to unman on qubes-users for explaining how to do this.

Define your defaults

In dom0: qvm-run MYTEMPLATE gnome-terminal

In the terminal that pops up, adjust settings to your liking.

Save settings template-wide

In the templateVM’s terminal:

sudo mkdir -p /etc/skel/.config/dconf
sudo cp ~/.config/dconf/user /etc/skel/.config/dconf/
sudo reboot

Subsequently-created VMs should now use the chosen settings by default.

This document was migrated from the qubes-community project
  • Page archive
  • First commit: 19 Oct 2019. Last commit: 19 Oct 2019.
  • Applicable Qubes OS releases based on commit dates and supported releases: 4.0
  • Original author(s) (GitHub usernames): null
  • Original author(s) (forum usernames): N/A
  • Document license: GPLv2