Service Vm's have network enabled

Hello! I was looking through the menu and i noticed that all service vms have "provides network "ticked in advanced settings of the chosen service vm. When i untick this box and than click apply, it then shows in the menu as a Domain. Is this normal?

That’s normal. The service VMs, such as sys-net, sys-firewall, and sys-whonix, provide networking to other VMs. Unchecking the ‘provides network’ box disables that VM from being an option for other VMs to use for networking. You might find that other VMs that rely on that qube for networking will no longer be able to connect to the internet.

Yea but for sys-usb i dont recall this being a default option.


So this may be a bug? sys-usb has networking enabled and I didn’t enable it.


i enable it to be able to use usb wifi


@NicholasTrust - I think you also reported on GitHub that your sys-usb did not
start on boot.
Can you say if you are using a USB network adapter?
Can you also say what USB devices you are using - mouse? keyboard?

If this problem still exists, then I would suggest that you remove
sys-usb with qvm-remove sys-usb
And recreate it, but deciding how best to do this will depend on answers
to these question.