Seriously can NOTHING be done about ImageMagick?

I have just spent the last three hours trying to figure out how to at least…since I was advised not to DELETE the damned thing (honestly, why not? It’s not like this particular VM is ever going to be sent a qvm-open-in-dvm)…get ImageMagick to not be the default viewer for images.

It CHOKES on my photographs; they are large files. And if I forget and double click them, I have to move the window off my screen (it covers the whole thing), open an Xterm in that qube, do a ps -flea to learn the process number, and kill it…I can’t shut it down; it’s too busy choking on a 45 MP file). It’s the worst piece of software I have to use right now. (It’s likely great for some 600KB thing downloaded off the internet; it serves that role admirably for the target of “open this anthrax-soaked file in dvm.”)

Yes I know I can theoretically issue xdg-mime commands, but this is in a disposable. I don’t want to have to do that every single time. I tried putting a script in the ./config/autostart_scripts directory in my DVM template (and it’s there so I put it in the right place), but apparently it didn’t execute.

I’m about ready to change the thunar desktop to point to a script that does the reassignments then actually opens thunar. But that’s clumsy. Can’t I just get rid of the damned thing? On ONE VM that will never be invoked from another VM? (Where IS it, anyway?)

Do it in the template

How to run applications at boot: Autoconnect VPN not working in Network Manager - #2 by BEBF738VD

And another option was suggested to you: Default applications by file type/cant get rid of ImageMagick - #3 by unman

The .config/autostart file that you suggested in the first thread you linked to? Doesn’t actually execute. I can start my disposable, I can go look and see the file is there (meaning I didn’t put it in the disposable, or in the TemplateVM, but rather in the DVM template)…but I put in a “touch” command to see if it ran and for some reason what I set gets overridden afterwords, or whether it just doesn’t run. It doesn’t run.

I suspect that’s something that doesn’t work in Debian. (I know I successfully use autostart or rather autostart-scripts in dom0. I tried both directories here.)

THIS: Default applications by file type/cant get rid of ImageMagick - #5 by otz actually worked. (Now I get to clean all the other crap out of my salt files, do this instead, regenerate TemplateVM, DVM-template, and named DVM, and hope it still works!)

BTW having the thunar desktop file point to a script that made the changes then brought up Thunar would probably have worked. Except that thunar was actually being brought up by “File Manager” which bypassed that particular kludge.

You should select it as a solution so it could help others. I hate ImageMagick myself too!

There’s no checkbox there on that thread. But I can select it here, and just did.

Yep, it’s because in guides section probably. Thanks.

I moved it to Support. You can try now.