Screenshots in dom0

Good afternoon, tell me where are the dom0 files? I took screenshots, they were saved to the pictures folder in dom0, but I can’t find the files and folder

Have you tried with the following ?

[user@dom0 ~]$ ls $HOME/Pictures

If you want GUI, press Alt+F2, type thunar and press enter.
Or open a terminal, type thunar and press enter.
Or press Ctrl+Escape, and Open in new window.
Or right click on your Desktop and Open in new window.

So many options…

1 Like

Also you can try out this screenshot tool, it can automaticaly upload your screenshot to AppVM:

Before that you might want to read this

It may be a concern. But you can easily change deepin-screenshot to xfce4-screenshooter in that script and it will work as well.

Thank you so much. It’s so easy from the desktop. And I’ve been looking for them for two hours. And nothing

Please tell me more. Through which application to open the screenshot. To open like pictures? And how can I copy them to another VM?

I think there is no image viewer in dom0 by default. You can copy files to your vm and open them there.

1 Like

It is not advised to run any apps in dom0 and templates.

I’m not doing something right, it doesn’t work out.I enter the command, qvm copy to vm I need to copy to anon whonix. Then I write anon whonix. And I throw a folder with pictures into the terminal? I’m not friends with the terminal can I explain something else?

It shows you the error that there is no such VM with name anon-whonix_clon. Check your VM name and try again.
To copy screenshot from dom0 to VM with name anon-whonix you need to run this command in dom0:
qvm-copy-to-vm anon-whonix /path/to/your/screenshot.png

1 Like

Sorry for the stupidity. I don’t understand the terminal. What is he giving me now? Files+? What should be done next?

  1. You need to write the exact name of your VM with in exact letter case. Check it once again. I think it should be anon-whonix-clone.
  2. You’re missing space between VM name and path to the screenshot file.
  3. The /path/to/your/screenshot.png is just an example of a path to your screenshot file in dom0 filesystem. Check the Desktop directory in dom0 to see the path to the screenshot file:
    ls -d /home/user/Desktop/*
    Then copy path to the needed screenshot to to qvm-copy-to-vm.

For example the path will be:
Then you need to run this command:
qvm-copy-to-vm anon-whonix /home/user/Desktop/Screenshot-1.png
Also you can use some helper script to not transfer the screenshots manually from dom0 to VM with qvm-copy-to-vm but using GUI. There are few of them and you can try them out:


Thanks. You are the best teacher. It almost worked. Even the folder was created in anon whonix with dom0, only nothing was copied there, already another red error in the terminal. Have a look?

  1. Don’t type spaces in path in terminal.
    / home / rutor / pictures / Screenshot_1.png
    Is incorrect. Remove the spaces:
  2. The linux is case sensitive so you need to type every letter in the exact case:
    pictures is incorrect
    Pictures is correct
    It’s not like in Windows and pictures and Pictures are two different directories here.

So the fully correct command will be:
qvm-copy-to-vm anon-whonix /home/rutor/Pictures/Screenshot_1.png


You are the best friend, you explain very clearly, with your help it turned out, and everything was transferred to the VM thank you very much)