Screen freezes and goes dark (cursor still moves)


  1. On alt-tab, ctrl+tab in a browser or just new window creation (also on non-native telegram notifications). Persists even if only dom0 started. Probably a few months with me (well since 4.1). Could happen after 18 hours uptime, could in a few minutes.
  2. Screen freezes (15% - clocks are still ticking, but nothing is responsive to clicks or keystrokes, including Ctrl+Alt+F3\4\5\6…). Sound keep playing though. And I’m able to move cursor in 90% cases.
  3. 90% - after a few seconds, screen goes black. 10% - stays like in stage 1 at least for a few minutes (and probably longer).
  4. I’m turning off by long pressing power button. On a next boot, there’s no “qubes domains” button in tray, qubes aren’t autostart, and pretty much everything’s broken so I restart via “Applications → Logout” menu.

Hardware: HP OMEN 15 2020 (Ryzen 7 4800H, NVIDIA GeForce GTX 1660 Ti, Kingston FURY Impact 2x32GB 3200MHz DDR4 CL20) + 1TB SanDisk Extreme Portable SSD (not a PRO\v2 version). I boot from external SSD mentioned.
Software: 5.15.48-1 kernel (5.10 - same), 4.14.5 xen.

What I’ve tried:

  1. Switched dom0 updates to “testing” (nothing)
  2. Disabled “Compositor” in “Window management tweaks” (nothing)
  3. Checked S.M.A.R.T. of SSD (good), applied watercooling since it was hot (nothing)
  4. Added “amdgpu.noretry=0” in dom0 /etc/default/grub (nothing; present in /proc/cmdline)
  5. Added “nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off” (nothing; not present in /proc/cmdline!)
  6. Tried 5.4.98-1 kernel cause 4.x aren’t present in 4.1 repos (failed, cannot boot with that, black screen)

Not related:
7. Installing 4.0.4 (black screen on Ventoy and even on <8GB partition without Ventoy)
8. Installing 4.1 on HDD (apparently 100-120 MB/s on “p10 game drive” is enough to produce io-specific errors)

Never peeked dmesg -Tw after those freezes, next time I will and update info.

I’ve tried to make the title a bit more specific, so others can find this more easily. Feel free to edit it if doesn’t perfectly reflect your problem.

1 Like

I added “nomodeset” as a kernel option, got minimum-brightness screen but not a single freeze in 2 days uptime. Which is good.
(guess nouveau was a problem)