Ryzen 5950x, ASUS ProArt B550-Creator

Remarks

(edit) Suspend not working, PS/2 mouse and keyboard not working at the same time, work separately

Haven’t had any (other) problems during daily usage.

Attachments

---
layout:
  'hcl'
type:
  'desktop'
hvm:
  'yes'
iommu:
  'yes'
slat:
  'yes'
tpm:
  'unknown'
remap:
  'yes'
brand: |
  ASUS
model: |
  ProArt B550-Creator
bios: |
  2423
cpu: |
  AMD Ryzen 9 5950X 16-Core Processor
cpu-short: |
  Ryzen 5950x
chipset: |
  Advanced Micro Devices, Inc. [AMD] Starship/Matisse Root Complex [1022:1480]
chipset-short: |
  FIXME
gpu: |
  Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] [1002:67df] (rev ef) (prog-if 00 [VGA controller])
gpu-short: |
MSI Radeon RX570  
network: |
  Intel Corporation Ethernet Controller I225-V (rev 03)
  Intel Corporation Ethernet Controller I225-V (rev 03)
memory: |
  65442
scsi: |

usb: |
  2
versions:

- works:
    'yes'
  qubes: |
    R4.1
  xen: |
    4.14.3
  kernel: |
    5.10.76-1
  remark: |
    not seen any trouble - all working
  credit: |
    CrisF
  link: |
    none

---
5 Likes

Good to know, what an interesting coincidence that i was just searching to see if others have 5950x running on qubes, and then you post. Looking to upgrade myself from a 2700x, just to have more spare cores for multiple running VMs

1 Like

I also couldn’t find info when researching so thought posting might help.

Hello @CrisF ,
please share also our experience of trying suspend.
Thank you very much.

1 Like

And with a PS/2 port :slight_smile:

Ok, tried suspend. It comes back to a pixelated kind of screen. I have been able to log back in, although not every time, but after 15~30 seconds the screen goes black and return to the pixelated screen, though still logged in. After clicking on any button back to log in.

1 Like

PS/2 port works but can’t get mouse and keyboard working at the same time. Individually mouse and keyboard work. Using a splitter cable 2 keyboards work at same time but 2 wired mouses don’t work when both plugged in together (neither of them). Mouse and keyboard don’t work together with splitter cable.

I tried a Microsoft Wireless Model 1045 PS/2 mouse & keyboard. The keyboard works, the mouse doesn’t connect with PS/2. This mouse & keyboard can also connect by usb and both mouse and keyboard work through usb.

1 Like

Let me know if there’s anything else I can test out.

Hi @naverone, I edited my original post, suspend not working and PS/2 has a few quirks I posted more about.

Thank you @CrisF for your HCL report, which is online now.

3 Likes

@CrisF did you have any issues with install or did it go well?

I was not able to get 4.1 or 4.0.4 to boot no matter what I tried when using the ProArt B550 Creator & 5950X along with an AMD GPU (XFX Speedster SWFT 210 Radeon RX 6600 CORE).

I was able to get it installed without any extra boot flags using Qubes-20220205-kernel-latest-x86_64

It may not install with C-state enabled so you can set it to Disabled if you can’t get the installer working:

In BIOS: Advanced > AMD CBS > Global C-state Control = Disabled

I also have Legacy USB disabled but not sure that matters.

I used the troubleshooting menu option but that shouldn’t matter.

Did you have to modify yours?