Run Mullvad browser in disposable

I’m trying to figure out how to start Mullvad browser in disposableVM and after closing the browser have VM shutdown automatically.

qvm-run --dispvm debian-11-mullvad-dvm “gnome-terminal --wait & cd /home/user/mullvad-browser && ./start-mullvad-browser.desktop”

The above is best I could come up with. Not great because I still need to close terminal to have VM shutdown automatically.

Any idea?

1 Like

Create a menu entry for Mullvad browser, add it to the disposable menu, click on it to start the disposable :+1:

1 Like

That doesn’t work. DispVM will start and immediately shutdown. Same behavior as running from terminal:

qvm-run --dispvm debian-11-mullvad-dvm “cd /home/user/mullvad-browser && ./start-mullvad-browser.desktop”

1 Like

Can you try to run directly:

… or is that the menu entry? You have to find the binary/executable for that browser.

—> more details:

Your startup script is probably trying to run the browser in the background.
What I mean is that this works (Firefox starts):

qvm-run --dispvm fedora-38-dvm "echo firefox > /tmp/exefire; chmod 755 /tmp/exefire; /tmp/exefire"

… and this does not work (dispVM will start and immediately shut down):

qvm-run --dispvm fedora-38-dvm "echo 'firefox &' > /tmp/exefire; chmod 755 /tmp/exefire; /tmp/exefire"

The difference is the tiny “&” after the “firefox” command.

2 Likes

Running directly like this won’t work because start-mullvad-browser.desktop can’t find the path to other files.

I can just extract everything in home folder and run:

qvm-run --dispvm debian-11-mullvad-dvm “./start-mullvad-browser.desktop”

But this will have the same effect as my first command (dispVM shutdowns immediately after starting).

Even simply starting gnome-terminal in dispVM won’t work correctly unless I add --wait option.

qvm-run --dispvm debian-11-mullvad-dvm “echo ./start-mullvad-browser.desktop > /tmp/exemullvad; chmod 755 /tmp/exemullvad; /tmp/exemullvad”

This also have the same effect (dispVM shutdowns immediately after starting).

Strange. Are you on 4.1 or 4.2?

4.1

I should mention that:

qvm-run debian-11-mullvad-dvm ./start-mullvad-browser.desktop

works in AppVM.

Also firefox in dispVM works with no problem:

qvm-run --dispvm debian-11 firefox

From Qubes OS documentation:

Note that currently only applications whose main process keeps running until you close the application (i.e. do not start a background process instead) will work. One of known examples of incompatible applications is GNOME Terminal (shown on the list as “Terminal”). Choose different terminal emulator (like XTerm) instead.

So with GNOME terminal I can use --wait option to get around this. Any idea how to do that with Mullvad browser?

Edit start-mullvad-browser.desktop and remove --detach.

1 Like

Trying this on Qubes. 4.2

This actually works? I just get a gnome terminal.

@throwaway5918 : I tried removing all three instances of “–detach” from the .desktop file and nothing changes, disposable vm still starts and shuts down without launching browser.

Make sure to also remove it from …/mullvad-browser/Browser/start-mullvad-browser.desktop not just …/mullvad-browser/start-mullvad-browser.desktop

It works for me like this:
Download and unpack Mullvad browser in Downloads folder then start a disposable terminal and run:
[user@disp989 ~]$ cd Downloads/mullvad-browser
[user@disp989 mullvad-browser]$ ./start-mullvad-browser.desktop
Launching ‘./Browser/start-mullvad-browser --detach’…
[user@disp989 mullvad-browser]$

That’s it. Worked fine in 4.1 and works fine in 4.2.

I’ve done other apps the way @solene said and they work just fine, too.

what’s special about mullvad browser?, have not looked into it yet

thoughts on librewolf?, it’s quite good at spoofing device information, sites can still detect true OS being linux.

Yeah it runs, the original goal was:

I’d add being able to launch the browser in disposable vm without having to go through the steps you mention of launching a terminal and typing commands. Like how disposable Firefox or Tor Browser works.

It’s Tor Browser without Tor - same protections and fingerprinting