Rufus UEFI install on Alienware?

Hi, I want to install Qubes onto a USB drive for my new Alienware x17 R1. It only supports UEFI.

Is it possible to use Rufus to do this?

What Ive tried so far today using a different Laptop:

  • Use Rufus to install the Qubes 4.1.iso onto a USB.

  • Installed Qubes onto another USB.

However, the USB drive isnt recognized by my new Alienware.

Specifications of my laptop:

  • Intel i7 11800H Processor
  • NVIDIA RTX 3070
  • Intel UHD Graphics

Any help please? Thank you =)

Welcome to the forum @XNights!

So if you enter the boot menu of your Alienware you cannot see the stick at all, and on another Laptop the same stick is booting fine?

What you could try:

iirc you can choose mbr/gpt in rufus. You could try it with the other setting and see if it works.

I had unsatisfying experience with rufus including booting on one machine and not on others, that is why i usually don’t use it. You could try other software:


  • Balena Etcher (never tried with qubes personally)
  • LinuxLifeCreator (never tried with qubes personally)


  • dd if=<ISO-file> of=<stick> bs=4k status=progress That is how i do it an it works every time (the stick is not damaged).
1 Like

I have two older Alienware computers, Skylake Intel.

I can go into BIOS/EFI and turn off Secure Boot. Change UEFI to Legacy. Then go to the boot screen and pick the boot from USB.

Let me guess. You already knew those things, and have discovered Alienware coroporate has disabled Legacy Boot?

I have used Balena Etcher from Windows 10. I prefer using the USB tools in Mint Linux. In the past I had some issues that Balena Etcher would not write a useful boot drive if the USB had been written to ?? twice before. Then I needed to completely reformat the drive somehow. That is, get rid of the boot partition, make the drive space one continuous area.

I have read some folks have had problems with Rufus, but that might be the OS they are using it from. ???

Best Wishes.

1 Like

11 generation Intel. Might need to upgrade Kernel inside install.
Also take a look at what software is needed for graphics chip/graphics card.

Hi, I made an install disk with Rufus, choosing UEFI only, & then booted into it & installed Qubes. I had to disable secure boot.

Everything installed fine, & Qubes is working!

I got the .iso from . I used the one from April 30th. The only things are that its a development build, & booting into Qubes a second time it only has the image background, & nothing is working.

Is there a kernel latest iso of the stable 4.1.0?

Thank you! =)