Root-move-from kioptrix kernel panic

i’m trying to create a lab with kioptrix level 1. converted to raw as the documentation said and created qube same [based on documentation]

I added 4 GB to the qube and 2 CPU and tried both with “include in max memory” enabled [with 6gb] and without it but it will not boot.
I’m stuck at Kernel panic: No init found. Try passing init= option to kernel.

The only thing from logs that is not looking good is this one qemu: pin_memory_cacheattr failed: Operation not permitted and from what I saw people are saying that maxmem should not be 0 but I changed that as well with qvm-prefts [same as from UI above] and still same error.
Any ideas?

The error from Kioptrix when trying to boot is

mount: error 19 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
Freeing unset kernel memory: 232k freed
Kernel panic: No init found. Try passing init= option to kernel

I founded how to fix that problem inside VMWare.
Changing the driver controller to IDE
How can I fix that problem inside qube?

Is it there a way to change the hdd to IDE in XEN?
This is the fix for VMWare but still I can’t make it work in Qubes OS

This also happened to people trying to run Android and ReactOS. See eg. Android runs fine in qubes, no mouse issue, But