Rise Up VPN for Qubes - polkit and iptables [R4.2]

I got polkit-gnome for F38 but that didnt fix it. There is no polkit for XFCE4.
Protonvpn-cli also wont connect. Suggestions?

@procShield there is nothing Qubes OS specific in your question, which is therefore off-topic in this forum. But you have reached trust level 2 and have access to our “All Around Qubes” category. This category is for Qubes OS related (but not specific) questions like yours. I moved the thread there.

1 Like

Installing polkit-1-gnome (on Debian11) solves the can’t find agent error message but VPN still does not connect. There is no polkit equivalent in F38.

Latest error message is /sbin/iptables , -t nat flush -PR-QBS None. Previously, I just had to follow the directions of the respective VPN for which OS and it would work. No iptables configuration. Did something change?

Qubes 4.2 dropped support for iptables. This may be the reason why you’re seeing this error.

Thanks. So I need to configure ip/nftables.

[protonvpn cli also no longer works on R4.2 so information on iptables configuration is needed]
nm-lib exceptions api session is not valid invalid refresh token

I’m not sure how this app works, but if you can turn off the in-app firewall then I think you can create your own custom rules using nftables.

For reference, the firewall doc is not updated yet for the change. A pull request was created to replace everything with nftables:

Honestly, RiseUp VPN never worked properly for me regardless of which OS I use /shrug

Worked for me up to quebesos 4.2 after the deb packages were updated per first link in previous post. From my understanding, all is missing is nftables support.

Weren’t they deprecating the .deb package in favor of the snap one? But yeah I did try to use them awhile back and it couldn’t even install because it was so outdated

RiseUp doesn’t work for me either. I’ve been testing various VPN softwares, I don’t know if it’s because AppVM has a volatile root. Or because of a connection problem. I’ve already tried openvpn too, and it doesn’t let me, I don’t really think it’s my connection problem, because I can still use extensions and that’s what I’ve been using so far (mozilla addons). I’d like to know if they find a solution to my problem, because I don’t really understand this very much, I’m a bit inexperienced and I find it kind of annoying to have to use extensions because they say firefox is not very secure.

1 Like