Ram detected in BIOS but not Qubes

So I have 2, 32gb ram sticks installed on my PC that I purchased a couple weeks ago or so to replace my previous ram as I needed more for better support running all the virtual machines I use. And upon initially installing them they worked fine and the full 64gb was available and being used by Qubes, but a couple of days ago is when I realized that for some reason now only 32gb/1 stick was accessible to Qubes. And upon booting BIOS the full 64gb shows up, and even with qubes if I run sudo dimidecode -t 17 in a dom0 terminal it will return results properly identify the ram as being installed. So my question is what should I do next to figure out why Qubes is rejecting the ram despite actively acknowledging it’s existent as being plugged in.

How did you realize?

Could you try running the following command in dom0 to see the amount of RAM detected by your system?

qubes-hcl-report | grep RAM

When I run the command you mentioned It only shows the one stick of ram. And I realized It when I was trying to boot up a VM that made my total go over 32gb of ram and Qubes told me It could not start because I did not have enough RAM available which I thought was odd and then quickly realized it was only utilizing half of what I had installed for ram.

Thank you for trying, and clarifying.
I would think it’s a RAM failure. In that case, even if the BIOS shows the correct amount of available RAM, the OS may not detect it correctly.
Have you tried running MemTest with each stick?

Ah, that would make sense as It is being detected but can not be practically used by the computer. I thought it was a little early for that as the purchase is fairly recent so I came on here to see if anyone else had experienced it and maybe had an OS side fix but what you’re saying aligns with the issues occurring. I have not run a MemTest but I shall now using MemTest86, I will report back the results after I am done.

You can change places of the ram modules and try again.
You can also use one module at a time and try again to find out if one of them has problem.

IIRC, the problem has never been reported as a Qubes-specific issue. If you would like to know if the problem caused by Qubes or not, you could do it by live booting Fedora or Debian etc.

Also if you didn’t get any errors in the test, try clearing the CMOS/BIOS by unplugging the battery from the motherboard with the two sticks installed.