R4.2.rc5 connected to printer via USB, recognised but cannot print




apt install printer-driver-escpr psutils cups


I’m using R4.2.rc5. It’s more comfortable to use than before.

I bought a new printer this time, downloaded the deb file from the official and installed it in the template (it was not displayed in the Application tab),

apt install printer-driver-escpr psutils cups

I installed and restarted the template VMApp, but even if I open the print screen with Brave, only the output to PDF is displayed. Is there anything else I can do?

Sorry, apparently I had posted this in Japanese. Thank you once again for correcting it in English.

1 Like

As first, before you search for other reasons, you have to enable the printer functionality (cups) in the qube, that you will use for printing:
(in dom-0 terminal)
qvm service -e <QUBE_NAME> cups
You can also do that on the settings dialog on that qube (Settings/Services), add the cups service (if it is not there) and enable it (tick the checkbox).

1 Like

Thanks. I added cups as a service by typing the command

qvm-service -e debian-12-xfce cups
that you taught me.

The untrusted one that wanted to use the printer did not seem to be reflected, so I selected it from the drop-down list and added it. It seems to be reflected after rebooting.

The cups one seems to have been enabled. At the moment, the printer I want to use, the EW-052A, does not yet appear from Brave’s printing.

How about running gnome-control-center and selecting ‘Printers’ in the qube that the printer is exposed to?

1 Like



with dom0 and untrusted, but it comes up as command not found. I am using xfce, so is there another command?

In Qubes 4.2 I found that a debian-based sys-usb was causing problems including not being able to get a printer connection.

Are you using Fedora 38 for your sys-usb template?

1 Like

I checked and it appears that debian12 is being used . Will switching to fedora38 cause any problems?


‘center’ is correct, not ‘centre’.
If you do not have that package in the TemplateVM, you just can install it in the TemplateVM and use it in the AppVM.

Or, system-config-printer package may be one of alternatives.

Probably not. Sys-usb doesn’t require anything special. But it’s easy to try it and find out. Just change the template for sys-usb, if no luck you can change it back.

If you find switching to fedora-38 does solve your problem we should probably report a bug related to this. My usb has always been finicky with Qubes so I thought it was just me.

1 Like

Thanks. Once I shut down sys-usb to change the sys-usb settings, nothing worked and I forced a reboot. I then cloned it and set Template to fedora38, can I change it in Qubes Global Settings? I think I can set one of them all to enabled and then set the existing sys-usb to Disable, but I don’t want to break the system again and want to go carefully.

Are you looking at USB Devices in Qubes Global Config?

I’m not sure how to change the assigned USB qube. I would try to change the template on your existing USB qube to fedora 38 and see if you can get that to work. If not, this is probably beyond my knowledge.

1 Like

You can temporary attach your USB controllers to dom0 to fix your sys-usb:

If you’ve already hidden that USB controller from dom0, you must revert the procedure by removing the rd.qubes.hide_all_usb option and employ an alternative strategy for protecting your system by physically disconnecting other devices during startup.

And you’ll also need disable sys-usb autostart so they won’t grab USB controllers from dom0.

1 Like

Thanks. I had finished my work and was about to start reading the documentation, but when I just connected the Printer USB to Untrusted, a dialogue came up and I was able to print. I am not sure how this became possible, but the command and installation I was running above seems to do the trick. It is unclear why it was able to do this over time, but it has been resolved! Thank you.

Thanks, I read the documentation presented by apparatus, and when I just connected the Printer’s USB to Untrusted, a dialogue appeared and I was able to run the print. I am not sure how it became possible to do this over time, but I am glad to have solved the problem! Thank you very much.