[R4.1-rc1] Openvpn issue after migration from R4.0

After migration to R4.1-rc1 my previously working VPN (openvpn) qube do not work anymore. Not sure why :frowning:
It CAN connect to the server And I see this message:

Initialization Sequence Completed

but network never works and after some time I see connection failed: No route to host and it try to reconnect.
Not sure how to fix it and what happened.
Previously, everything worked without troubles.

Already tried: 1) change ip range from 198.0.30.* to 10.8.0.*
2) recreate vpn AppVM.
3) change all scripts (qubes-firewall and vpn-handler) to actual versions from this: https://github.com/Qubes-Community/Contents/blob/master/docs/configuration/vpn.md

Maybe something changed at network rules (iptable, nat, route) related at R4.1?

I think that problem at ‘qubes-firewall-user-script’. It do not work anymore like expected.

update: tried with other openvpn instance that previously work. The same problem :frowning:
update2: posted routes after connect below

sudo sg qvpn -c "ping google.com"
ping: google.com: Name or service not known

This also not work with current qubes-firewall-user-script, but it can ping

looks like this because old openvpn client upgrated to new one 2.5+
Not sure how to fix my configs :frowning:

Routes after connect to open vpn… Is something wrong?

sudo route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface UG 0 0 0 tun0 UG 0 0 0 eth0 U 0 0 0 tun0 UH 0 0 0 eth0 UH 32714 0 0 vif38.0 UG 0 0 0 tun0
SERVERIP UGH 0 0 0 eth0

THIS HELPS!!! User -> Tor -> VPN -> Internet - 4.1 broken? - #3 by star
100% Qubes R4.1 bug
@marmarek @adw