QWT installed but no USB or file copy in Windows qube

I installed the Windows tools, but that gave me audio only. When I attach USBs to the Windows qube, they never show up in Computer. When I try to copy a file over to the Windows qube, the error message “failed to execute qubes.Filecopy” pops up.

How exactly do you do this?

With Qubes Devices

There are two ways of adding it via Qubes devices…

I start the Windows VM.
I plug a flash drive into the computer. I click the little purple icon for Qubes Devices. When the graphical menu opens, I mouseover the name of the flash drive I plugged in, and, when the submenu for that device appears, I click the name of the Windows VM. A system notification pops up saying that the drive has been attached.

Then I check Computer in the Windows VM to see whether a new drive has been detected.

Ok. Each storage device you can attach as an USB or a block device. You should try to attach it as block device, whole device and not a partition. Equivalent terminal command would be

$ qvm-block attach WinQubeName dom0:sda

for example. If that doesm’t work, try from the terminal with persistent argument prior to boot windows

qvm-block attach --persistent WinQubeName dom0:sda

Note that sda is example. You should put the right letter from your device

USB equivalent command would be qvm-usb attach…

EDIT: nevermind, I just figured out that this installation has no USB driver installed. But I still need to figure out the problem with copying files from other qubes.


so do I understand it right that a stock Windows installation doesn’t provide a USB driver and you managed to install one manually and now everything works? If that’s the case, could you give us a tip, where to get one from a trusted source?

No, I have not managed to install a USB driver. I assume one would be installed automatically if the Windows troubleshooter I ran was allowed to access the Internet, but I can’t test that because my installation also has no network driver.

Attaching any block device via sys-usb most likely won’t work, and that is why it is strongly suggested to attach it as a block device. To know if you properly installed QWT just try to attach some non-block device - some usb wifi adapter or similar and try to attach it to win qube. It should work.

All of these could be read on the forum, for example here

Did you for example installed these drivers after QWT?



Not to say we still don’t know which Windows you are using.

That’s weird - for me I had to install the Dell USB drivers and then pass a USB device to a qube rather than a block device. It then prompted for installation of drivers for that USB drive and now it works.

I’d be happy to write documentation for that in the Community Docs but I’d be glad if more people could test, whether that was the right way of doing things.

It’s not that simple…