Qvm-template-gui in 4.1rc2 not working

After installing 4.1rc2, opening qvm-template-gui shows a list of templates available for download.

It seems that no matter which templates are selected for install, the result is a bunch of “download failed, retrying” error messages, then it gives up having transferred a total of 0 bytes.

Is this because i selected for it to do “updates over tor”? I tried changing in the qubes global settings the dom0 update qube to sys-net instead of sys-whonix. I then tried doing a update of dom0 through the update manager and that successfully updated. But qvm-template-gui still gives “download failed, retrying” error messages.

it worked on the 4.1rc1 install, but not 4.1rc2

One change between the installs was that I selected debian for my 4.1rc2 system qubes instead of fedora for 4.1rc1

Any ideas? I don’t understand what qvm-template-gui is supposed to use for its network path.

(note: not running in sys-gui)

Hi @ddevz

The qvm-template-gui download works on my Qubes-OS 4.1rc2. I suggest you switch back to Fedora as UpdateVM, see #6985.