Qvm-open-in-dvm loop

Every time I try to view an image in a disposable, it starts a disposable qube, when that qube has started, it starts another and so on until I reboot. Nothing I tried can end this loop without a reboot.
I didn’t know where to post this as I don’t need support per say, but not sure I’m qualified to open an official bug report.

Yes, thank you for reporting. There’s already an issue for this phenomenon.

1 Like

Thank you!

Two hints:

  1. you can change the policy from allow to ask … that way you’ll
    get a dom0 dialog which you can select Cancel in and break the chain.

  2. I suspect you somehow set the MIME handler for images to
    qvm-open-in-dvm in your disposable template… that would explain what
    you are seeing.

It is indeed #2, but I found that even if I set a specific disposable for a disposable template, the created disposable always has itself as disposable instead of the one set for it’s template. Not a big deal but it might exacerbate this issue.

I was not aware of #1, I don’t know how to implement it but I’ll certainly look into it. Thanks for sharing!

1 Like

Hey if a MOD wants to change the title of this thread to something more meaningfull, by all means please do. :slight_smile:

1 Like

@Gartech: I changed the title and moved the thread into ‘user support’. As for the policy open or create /etc/qubes/policy.d/30-user.policy and modify/add these lines:

qubes.OpenInVM          *           @anyvm          @dispvm     ask
qubes.OpenInVM          *           @anyvm          @anyvm      ask
qubes.OpenURL           *           @anyvm          @dispvm     ask
qubes.OpenURL           *           @anyvm          @anyvm      ask

You can use default_target= after the ask to specify a qube to be pre-selected in the dom0 dialog.


Perfect thank you!

I checked to enable what you proposed as it seems perfect for my use case, but /etc/qubes/policy.d/30-user.policy does not exist for me.

Shall I create it and append the lines?

Yes. Check also 90-deafult.policy at the spot, maybe you get additional ideas too what else to put in 30-user.policy. Since R4.1 it’s all in one place now.

typo :wink: :point_right: 90-default.policy

to check the content
nano /etc/qubes/policy.d/90-default.policy

and here the whole documentation:

1 Like

Corrected, thanks. I was dealing with the 99-zram.rules at the moment, and naturally…