Quite electric noises (maybe active SSD usage on system idle)

I have Thinkpad T16 Gen 1 and it makes this quite electric noises when I use Qubes OS even in idle. Kubuntu does not produce them during idle.
I had similar noise on different laptop, it’s not monotone, but like very quite HDD working (e.g. copying files), but more electric,
I think it can be from M.2 SSD (strange idea but I have no better).

  1. If somebody has other ideas about were this quite electric noises can be - please tell me.
  2. Is there a way to check what is writing/reading data actively on system idle in Qubes OS (preferably real-time). I see that there is no active writing to dmesg or journald on idle in dom0.

You may want to try xen package from testing repository, specifically this update: vmm-xen v4.14.5-17 (r4.1) · Issue #3531 · QubesOS/updates-status · GitHub
It has “Intel HWP” support included, which may help here. But as usual with testing package, you may hit some issues. If needed, downgrading back to previous version is described on the same documentation page.

1 Like

Had something like this happen on an old thinkpad. Strange electric noises would happen as the computer worked on something. It was troublesome to boot (only booted like 50% of the time). Then it stopped booting altogether. I’m guessing a cap failed on the motherboard or something. Tried swapping ram sticks, but that did nothing. It’s now a brick.

1 Like

Thanks. With this message do you mean that noise comes from fan, or how HWP can be involded?
I still expect the reason to be an unnecessary SSD activity during idle, so is there a way to check disk activity (reading/writing) on Qubes OS?

I have this on old Macbook Pro Retina (my HCL report) on any GNU/Linux and it still works fine. I am not sure if it is a defect or not.

It might be fast CPU frequency changes or other power state changes, and sometimes changes in power draw results in audible noise from power circuitry. Anyway, that’s a long shot, it might be something totally different.

1 Like

Testing repo seems to have only 4.14.5-15:

$ sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing xen
Package xen-2001:4.14.5-15.fc32.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

you need to add --action=update

1 Like

No - I’m running 5-17 myself.

qubes-dom0-update --action=list --enablerepo=qubes-dom0-current-testing xen

Installed Packages
xen.x86_64            2001:4.14.5-17.fc32             @System                   
Available Packages
xen.src               2001:4.14.5-17.fc32             qubes-dom0-current-testing

1 Like

xen update (v4.14.5-17) does not seem to be changing anything with noises.
Any help how to check the writing/reading of Qubes OS in idle?
With only dom0 running - the sound is rather quite, so I consider the problem to be some disk activity (not desired). But I do not know how to check this idea, any advice?

Run iotop and see if noise increases when disk usage increases.
Or run some command in dom0 which will increase disk usage like dd and see if you get some noise.

1 Like