QubesOS GUI becomes very laggy on new computers

hello everyone:
I’ve been using QubesOS on my old laptop. I installed qubes on an external ssd and booted from it. QubesOS was working fine until I changed to a new laptop and the qubes didn’t seem to be working very well.
First of all, qubes cannot be recognized by uefi, so I had to manually change some files of the efi partition according to the document. Luckily this worked and I got into qubesO successfully.
However, when I entered the system, I found that the screen and mouse were very stuck, and the screen scrolled from top to bottom to refresh. I can’t use this to work. (When I boot from an old laptop, there is no such behavior)
Is this a problem with the display? Or is the computer itself not well adapted? The current display resolution is 2560*1440, and the refresh rate is 144hz.
I checked the problem solving document and executed this “qvm-features dom0 gui-videoram-min 64000” command to expand the video memory , but the effect is not obvious.
With my ability, I can only do this step. I hope someone can help me provide a solution. Thanks a lot.

Could you share some specs about your new computer? The title is using plural for computers, did you try on multiple computers?

Did you drive the drive to the new computer, or did you install a fresh Qubes OS on the new computer? The EFI changes you made make me think you moved the drive. I don’t know much about Qubes OS installer, maybe it does something special when detecting hardware. (but for Linux in general, it should works fairly well anyway).

The new computer uses a clevo motherboard.
Only tried it on two computers, the old one worked fine.
I plug the external ssd with qubes into these two computers to boot.not a fresh install on the computer.

Have you tried booting qubes os with kernel-latest ? I had the same issue on a new desktop pc and that solved it.

whats kenel-latest mean?could you please share some specs

At boot time you should be able to select a different kernel. By default (at the time of writing this post) the kernel is 5.15.x, while kernel-latest is 6.x. ; so select kernel-6.x (eg. kernel-6.3.2 if you’re up to date).

also, what graphics is your device using? integrated or discrete? eventually you’re letting your CPU render all the things because the driver for a discrete graphics adapater is missing?

thanks a lot,taradiddles.
I didn’t find any more kernel versions in the boot screen. But I saw it in the install media. Then reinstalled the system with this option including kenel-latest. Perfectly solved the problem of system laggy.
But when I install various qube, finally pop up “sys-firewall filed…internal error:unable to restart pci divice…”
more and more problems…so hard…

Qubes OS compatibility is quite tricky due to Xen and PCI passthrough. If you really want to use Qubes OS, you should get a compatible hardware, otherwise you would have to report bugs, experiment and hope for fixes.

See Qubes OS Documentation: Choosing your hardware