QubesOS 4.1 post-installation initial setup hangs at "Executing qubes configuration"

As you can see in the picture below, the setup process hangs there. I have been waiting on this screen for 30 minutes. The processor light isn’t blinking, and the mouse cursor is non-responsive. I have had to hard-shutdown the computer.

Why does this occur? This happened again when I installed v.4.0, too.
Is this an error that might blow up my OS’ working down the line?

Machine: Thinkpad X220-i52520M, 16GB RAM.

That part of the Qubes OS installation usually can take quite a while. I would suggest leaving the computer running in the background during this part (in a secure physical location) and coming back to it later. Also, do you have a HDD, or SATA SSD?


I have an SSD. Samsung 860 EVO 1 TB.

Hey, you were right! I tried installing qubes os 4.1 from scratch and left my computer in my room connected to the power outlet. And when I came back after 45 minutes or so, the post install setup was completed and I was ready to log in to my system.

Thanks for the suggestion!


Hello I have the same issue but even waiting 6+ hours nothing changes.

The first install attempt was about two hours before I restarted.

Second install try was about 7 hours because I set it before I slept.

Not sure what to do next? It’s a heads x230 i7 system with 1TB Samsung SSD also.

Thank you.

I looked around the forum and changed USB and port just to make sure it’s not that. Also saw something mentioned about Samsung drives having a problem with LVM so I switched to BTRFS. Still didn’t change Current hung at “Executing qubes configuration” for about 2 hours now. I’ll leave it for about another 2 hours and see what happens, but doubt it will work.

Additionally would like to mention that as soon as it says “executing qubes config” the mouse freezes. But before you can also move mouse as it goes through it’s different setup procedures.


anyone else out there getting completely stuck?

Thank you for any help that can be shared.

Maybe sys-usb creation is failing. Try to uncheck it and run configuration. If it still fails try to configure only templates. If they’ll also fail then try to finish configuration with “don’t configure anything” check enabled.


yes worked. I just installed the templates. When it finished recieved error “disp_vm missing DVM failed”.

If you or anyone can point me in the direction of setting up whats missing on r4.1 I’ll do the manual route until I figure out the installer problem later. Mainly need those dispvms, want to try disp firewall and disp USB, sounds useful!

Thank you all.