Qubes won't start after 4.1 -› 4.2 upgrade

After I installed xen 4.17, the system will not start anymore, “Disk password” label is not shown, but otherwise the screen is there, it’s possible to type in password, but after that, it won’t start the X-Server, or something like that.

tty1 is blank, I can switch to tty2, tty3, and I can see login prompt.
I’m even able to log in.

But, there is no GUI, and it is also not showing any error.

The installation process went like:

  1. I tried to install from the graphical user interface, it said some error after long download time, it said that I need to stop all qubes. Then I did that,
  2. Installed updates with sudo dnf upgrade, if I remember well.
  3. Installer said Complete!
  4. I was not able to open Qubes Manager, or click on update icon any more, in the tray
  5. I rebooted the system
  6. System won’t start again.

I can run sudo commands in tty2.

End of /var/log/boot.log:

[OK] Finished Start Qubes VM sys-usb.
     Starting Permit User Sessions...
[OK] Finished Permit User Sessions...
[OK] Started Command Scheduler.
     Starting Light Display Manager...
     Starting Hold until boot process finishes up...

Did you follow this guide when you’ve tried to upgrade?

I can’t make sense of what exactly did you do.
Can you describe step by step what did you do to upgrade?
Because I don’t know why did you mention installing xen 4.17 or what did you mean by “tried to install from the graphical user interface” or why did you run sudo dnf upgrade and where did you run it.

1 Like

I did that thing that you showed some weeks ago, system worked after that, and, as I know understand, upgrade was not finished, because a major xen upgrade or dom0 update needed to happen, in order to fully upgrade. So, I think, I was 90% done for like 1-2 week, because the dom0 update I didn’t do, I just run --pre-boot --post-boot 1-2 weeks ago.

EDIT: sudo dnf upgrade I run in dom0, and I run it, because it said that I can’t update the system without stopping all qubes, except for dom0. So, the graphical user interface downloaded the update, and then exited with an error, and I finished it in dom0.

If it’s related to messed up upgrade then I don’t know how to fix it easily.
I’d just backup my qubes and go for a Qubes OS reinstall.

You can check lightdm service log for errors in dom0 terminal:

sudo systemctl status lightdm


sudo journalctl -b -u lightdm

Maybe if you search the forum for these errors you’ll find some solution.

1 Like

Yes, it’s failed.

Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not activate remote peer.