Qubes won't let me click anything on home screen (NitroKey Laptop)

Total Qubes/Linux newb here. Trying to move away from Apple.

I received my new Qubes-certified hardware from NitroKey yesterday. Booted it up. Updated it. I figured out how to get past the initial startup problems post update and got back to my home screen with Qubes updated.

The problem is that now the computer won’t let me click on anything (right or left click) on the home screen. I can hover my cursor over some of the homescreen buttons and will get popup info, but the system won’t let me click anything. It’s like the OS is frozen but the cursor still moves.

I’ve restarted a bunch of times and the same situation happens. Several times I’m able to do ONE THING–like bring up the qubes manager or bring up a firefox window. But then I’m not allowed to do anything else outside that one task… for example I can navigate inside the browser but can’t close out the firefox browser qube or click on anything outside that qube. The entire computer is “stuck” until I restart it. Several times the home screen won’t respond to any actions I take.

Is there something that I toggled during the update process that would royally mess up my brand new computer so bad that I can’t even use it?

I’m about to give up on Qubes because I can’t even get started.

Sad to hear this happened to you. Especially for certified hardware where it is more tested than any other.

Could this be a mouse defect? (the button not clicking properly) This would explain why you get popup info and only rarely a click.

Bellow I give you two options about how to test it. If work can do things this way, then it’s definitely a mouse problem and you’ll have to contact the product support, unfortunately.

This really shouldn’t be the first experience the user has with Qubes…

Option A (using only the keyboard)

Can you try clicking:

  1. Alt + F3 (and then the “application finder” will show – kind of like apple’s spotlight but more primitive)
  2. From there type an application you want. For example type “work firefox”
  3. Use the Tab, arrows and “enter” keys to move around

Option B (USB mouse)

Could you try plugging in a USB mouse to to see if that solves the issue? (note: for security reasons, you should get a prompt asking you if you trust said mouse. You should be able to use the keyboard to select that option (using the “tab” and “enter” keys)).

I don’t think it’s a mouse issue.

I’ve tried USB mouse and the track pad mouse/buttons and the “ThinkPad” eraser head mouse/buttons. Same thing… They work great on restart… right up until I get to the home screen. I get about one shot to open a qube. Outcome 1: Qube opens and I may or may not be able to navigate within it. Everything outside the qube is non-functional. Outcome 2: nothing responds to anything I do.

Ok. I tried the Alt-F3 thing.

It worked. Brought up the new window. I typed “personal firefox” and the option came up.

I went to click on the option by mouse. No response. I went to tab to the option. No response.

I hit Alt-F3 again to see if it would close the new window. It opened a new application finder window… that would not respond to the keyboard or mouse.

Then mouse would not allow me to click back on the first application finder window that popped up. Now I have three open Application Finder windows in the same qube and nothing is responding to keyboard or mouse.

Alt-F4 closed those windows. I put the screen to hibernate.

When it woke up, then Alt-F3 brought up a new Finder Application window that did respond to keyboard… but then won’t let me click on the “Personal Firefox” option.


I unplugged the USB-mouse. Seems like I got control back??? Maybe the problem was just a mouse issue.

Thank you!

1 Like

Good to hear. Let’s hope it is that.

Just in case, you should reach out to Nitrokey to inform them of this issue. Their quality assurance should have caught this before shipping.

@BraveNewWhorled feel free to get back to the thread if the issue persists and NitroKey was unable to help.